Download it now!
Bug 55754 - FORMATTING: Conditional Formatting conditions don't work
Summary: FORMATTING: Conditional Formatting conditions don't work
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.2.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-10-08 09:36 UTC by xion87
Modified: 2015-03-21 20:27 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Here is an example, i select the coloum and put the conditional formating (value = b) it must colour only the " b" cell, but it colour emply cell instead.. (45.97 KB, image/jpeg)
2012-10-08 09:36 UTC, xion87
Details
Native file conditional formatting setup correctly but no rendered correctly. (8.63 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-05-06 12:03 UTC, skiani
Details
Same sample case created in Excel, import now renders correctly (9.07 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2013-05-06 12:03 UTC, skiani
Details

Note You need to log in before you can comment on or make changes to this bug.
Description xion87 2012-10-08 09:36:26 UTC
Created attachment 68248 [details]
Here is an example, i select the coloum and put the conditional formating (value = b) it must colour only the " b" cell, but it colour emply cell instead..

Problem description: 

Steps to reproduce:
1. write some thing on more rows
2. select coloumn
3. go to Conditions formatations--> Conditions formatations (im using italian version so i dont sure if there are the correct names)
4.write a condition, like =world and put some format and press ok

Current behavior: it dont format, it format only empy cells

Expected behavior: it must format the correct world

Platform (if different from the browser): 
              
Browser: Iron/21.0.1200.0
Comment 1 leo.moons 2012-12-17 21:15:18 UTC
I can reproduce the bug under Windows 7 LIBO version 4.0.0 beta 1

Text is not recognised in condiotional formatting

Best regards

Leo
Comment 2 Jorendc 2013-01-25 00:28:08 UTC
I also can reproduce using LibreOffice Version 4.1.0.0.alpha0+ (Build ID: b1d0fd4f969976e2133f8eaa37c1fb8360c20f6)
TinderBox: MacOSX-Intel@1-built_no-moz_on_10.6.8, Branch:master, Time: 2013-01-24_00:28:35

Mac OSX 10.8.2

@moggi: I think because of the bug title you bug filter didn't pick this one up. Therefore I cc you and correct the bug title.

(In reply to comment #1)
> I can reproduce the bug under Windows 7 LIBO version 4.0.0 beta 1
Hi Leo; Feel free to set bug status to 'NEW' if you can reproduce this behavior. Thanks for testing!
Comment 3 skiani 2013-05-06 12:01:42 UTC
Same problem. Pretty significantly breaks ability to work. I will attached a couple simple examples.
Comment 4 skiani 2013-05-06 12:03:13 UTC
Created attachment 78920 [details]
Native file conditional formatting setup correctly but no rendered correctly.
Comment 5 skiani 2013-05-06 12:03:53 UTC
Created attachment 78921 [details]
Same sample case created in Excel, import now renders correctly
Comment 6 QA Administrators 2015-03-04 02:19:36 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1.2 or later): https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior

If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

Thank you for your help!

-- The LibreOffice QA Team
This NEW Message was generated on: 2015-03-03
Comment 7 Jean-Baptiste Faure 2015-03-21 20:27:01 UTC
Not reproducible for me with LibreOffice 4.4.3.0.0+ built at home under Ubuntu 14.10 x86-64. Conditional formatting works as expected including condition value on text.

Closing as WorksForMe. Please, feel free to reopen if you still encounter the same issue with one of the current stable versions or the master.

Best regards. JBF