Bug 55854 - Windows Search
Summary: Windows Search
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
(earliest affected) release
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
Keywords: regression
Depends on:
Reported: 2012-10-10 20:26 UTC by John Schuetz
Modified: 2015-04-22 08:04 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Note You need to log in before you can comment on or make changes to this bug.
Description John Schuetz 2012-10-10 20:26:51 UTC

Comment 1 John Schuetz 2012-10-10 20:29:53 UTC
Shortly after libreoffice is installed, SearchHostFilter.exe uses very high CPU for a number of hours.  After it is done, odt files do not show up on the Windows 7 Search results.  If I uninstall and re-install 3.5.6, the install goes fine and I am able to see the odt files in Windows 7 Search results.
Comment 2 John Schuetz 2012-11-03 18:57:11 UTC
A little more light on this.  I tried again with  SearchHostFilter ran again as described before, slowing down after a few hours.  Still no odf filetypes in the Windows Search results.  Re-installed 3.5.7 and SearchHostFilter ran a few minutes, then slowed down, and odf files appeared in the search results.

The interesting thing is that when looking at the indexing results, virtually the same number of files were indexed.

Note I tried different ways of installing and got the same results (removing 3.5 first, renaming the LibreOffice file in the AppData/Roaming before installing, also restoring the 3.5 install and installing 3.6 on top).

I hope that this gets resolved and 3.5.7 won't be the end of the line for me (and I assume others who have this problem as well.)
Comment 3 Karlheinz Lorenz 2013-02-08 16:45:16 UTC
Same observations with LO 3.6.4 and 3.6.4! I tested several times on different machines and under Windows7-Ulimate-32bit, Windows7-prof-64bit and Windows XP SP3 and it is always the same. So I confirm John's bug report.
There is a simple workaround: Just save the dlls of 3.5.7's folder ..program\shlxthdl\ and replace the correspondent dlls of 3.6 with the old ones and windows search indexing will function properly.
There is an equivalent Bug report: "Bug 56035 – Indexing for Search not working" in a different section: Component "LibreOffice".
Comment 4 josiasmat 2013-11-30 00:35:23 UTC
Apparently a duplicate of bug 68487.
Comment 5 QA Administrators 2015-04-19 03:21:22 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   *Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1 or later)

   *If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
   *If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   *Update the version field
   *Reply via email (please reply directly on the bug tracker)
   *Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)


2. Test your bug 
3. Leave a comment with your results. 
4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword

Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-04-18
Comment 6 John Schuetz 2015-04-22 03:03:56 UTC
I'm running LibreOffice 4.4.2 (just updated) on Windows 8.1 (x86); I no longer see this problem happen.