Bug Hunting Session
Bug 55876 - Improve the look of selected text
Summary: Improve the look of selected text
Status: RESOLVED DUPLICATE of bug 57894
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
3.6.2.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-10-11 14:51 UTC by Alexandre Demers
Modified: 2017-09-03 14:43 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
text selection with blinking cursor (24.13 KB, image/jpeg)
2012-10-11 14:51 UTC, Alexandre Demers
Details
Text selection in LibO 6.0.0.0.alpha0+ (end of August 2017) with cursor at left beginning (3.41 KB, image/png)
2017-09-02 22:29 UTC, Thomas Lendo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexandre Demers 2012-10-11 14:51:36 UTC
Created attachment 68441 [details]
text selection with blinking cursor

When selecting text, there is a border around the selection that could be removed. It is unaesthetic and useless. Also, when the cursor blinks, it looks strange because of the border, making the border disappear.
Comment 1 Roman Eisele 2012-11-27 19:32:47 UTC
Comment on attachment 68441 [details]
text selection with blinking cursor


(Fixed attachment MIME type.)
Comment 2 Roman Eisele 2012-11-27 19:38:20 UTC
Definitely a valid enhancement request, therefore I set the Status of this report to NEW.

(I can confirm the unnecessary border; tested with LibreOffice 3.6.4.1 on Mac OS X 10.6.8 (Intel). The border goes back to the days of OOo, and maybe is even older ... but this is not important for an enhancement request.)

However, we should be aware that it is quite possible that *some* users like the border, and will complain if/when we remove it ;-) So, some discussion on the UX advise list seems advisable, before removing the border.
Comment 3 Emir Sarı (away) 2012-11-28 02:20:09 UTC
I think LO should use the default highlighting of the OS. Especially in OS X Calc, it is nearly impossible to determine which cells are selected.
Comment 4 Alexandre Demers 2012-11-28 04:07:34 UTC
(In reply to comment #3)
> I think LO should use the default highlighting of the OS. Especially in OS X
> Calc, it is nearly impossible to determine which cells are selected.

I agree this would be a great idea.
Comment 5 Roeland 2016-09-15 18:49:13 UTC
On the topic of calc, Bug 56846  is related.
Comment 6 Thomas Lendo 2017-09-02 22:29:34 UTC
Created attachment 135974 [details]
Text selection in LibO 6.0.0.0.alpha0+ (end of August 2017) with cursor at left beginning

Is this still an issue since now it looks different than at creation of this bug report. Personally I like it as it is.
Comment 7 Adolfo Jayme 2017-09-03 04:41:50 UTC

*** This bug has been marked as a duplicate of bug 57894 ***
Comment 8 Heiko Tietze 2017-09-03 07:15:11 UTC
(In reply to Adolfo Jayme from comment #7)
> 
> *** This bug has been marked as a duplicate of bug 57894 ***

What is the native highlighting, Adolfo? Ddespite the color of course. And do you really want to add text highlighting to the cell topic?
Comment 9 Adolfo Jayme 2017-09-03 09:35:59 UTC
(In reply to Heiko Tietze from comment #8)
> What is the native highlighting, Adolfo? Ddespite the color of course. And
> do you really want to add text highlighting to the cell topic?

The native highlight is a solid mark which is identical to what a text editor like Kate, gedit or Notepad produces. We need that. Our current highlight might be useful only in spreadsheet, but we should totes look at how NeoOffice does it and emulate that.
Comment 10 Heiko Tietze 2017-09-03 14:43:27 UTC
(In reply to Adolfo Jayme from comment #9)
> (In reply to Heiko Tietze from comment #8)
> > What is the native highlighting, Adolfo? Ddespite the color of course. And
> > do you really want to add text highlighting to the cell topic?
> 
> The native highlight is a solid mark which is identical to what a text
> editor like Kate, gedit or Notepad produces. We need that. Our current
> highlight might be useful only in spreadsheet, but we should totes look at
> how NeoOffice does it and emulate that.

This ticket requests exactly what you describe. My question was about the implementation where I'm not aware of any specific draw method. 

I'm looking for something like https://msdn.microsoft.com/en-us/library/windows/desktop/bb226803(v=vs.85).aspx or http://www.catch22.net/tuts/mouse-selection-highlighting because using native controls wouldn't require any additional effort. 

And finally I would keep this ticket open as the duplicate is very Calc specific.