Bug 55958 - Watermark cannot display special Slavic (non-Windows-1252) characters by default
Summary: Watermark cannot display special Slavic (non-Windows-1252) characters by default
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
3.6.2.2 release
Hardware: x86 (IA32) Mac OS X (All)
: medium normal
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-10-13 20:28 UTC by miles
Modified: 2014-04-20 19:25 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Watermark without č (14.26 KB, application/pdf)
2012-10-14 23:37 UTC, miles
Details
Watermark with č (21.36 KB, application/pdf)
2012-10-16 19:25 UTC, miles
Details

Note You need to log in before you can comment on or make changes to this bug.
Description miles 2012-10-13 20:28:05 UTC
Made a watermark with some text that included č (c with caron) and the watermark does not contain it, there is an empty space and following characters get misplaced a bit.
Comment 1 miles 2012-10-14 23:37:48 UTC
Created attachment 68563 [details]
Watermark without č

This is a sample document that had " če če " entered as watermark, but displayed only " e e", as can be seen in the resulting pdf.
Comment 2 Roman Eisele 2012-10-16 12:44:53 UTC
Thank you very much for your bug report!

Thank you especially for the sample .pdf file. Looking at this file with Adobe Reader (10.1.4, on Mac OS X 10.6.8), I see that the font used for the watermark is “Heveltica”, and that a (Postscript) Type 1 font version of “Helvetica” is used for the display, while the source font was “Helvetica” in TrueType format. So the original font for the watermark is not embedded, but the default (Adobe Reader?!) version of “Helvetica” is used instead.

I wonder why this could be a/the reason for the missing characters: automatic font substitution, while a nice feature in theory, often causes headaches like this one.

Could you please try: When exporting your file to PDF from LibreOffice, check the “Embed standard fonts” option (in the first pane of the “PDF Options” dialog window, at the bottom right). Does this change the situation, i.e., does the PDF exported now look different? Are the č characters now present, or still missing?

Please try this; thank you very much in advance!
Comment 3 Roman Eisele 2012-10-16 13:52:41 UTC
I have just tried it myself with LibO 3.6.3.1 on Mac OS X 10.6.8 (Intel); I can CONFIRM [REPRODUCIBLE] that the watermark text (I used “če če”, too) is NOT exported properly by default, but it is exported correctly if I check the “Embed standard fonts” option.

So please check if this fixes the issue for you, too; then we can decide if/what further steps are necessary.
Comment 4 miles 2012-10-16 19:25:14 UTC
Created attachment 68643 [details]
Watermark with č

Hello, this is now a demo pdf with same watermark text " če če ", this time with option “Embed standard fonts” enabled, as you noticed before.
So what should be done?
Comment 5 miles 2012-10-16 20:09:51 UTC
Added "by default" in the title of this bug.
If option "Embed standard fonts" in the PDF Export dialog is not selected, the watermark does not display non-ASCII characters (at least Slavic ones). It is a bug.
Comment 6 Roman Eisele 2012-10-17 13:28:38 UTC
Futher tests:
1) If I try some other non-ASCII characters, e.g. “äöüßáéë”, they are exported correctly to the watermark, even *without* checking the “Embed standard fonts” option. So the problem does not appear with all non-ASCII (non-7-bit) characters.

2) Even exporting the characters “nšžðn” works without checking the “Embed standard fonts” option. But “č” does not work. So what characters are supported by default? Adobe Reader says that the encoding of the non-embedded Helvetica text was “Ansi”. Well, many people refer by “Ansi” to the Windows-1252 codepage.
See e.g.
    http://en.wikipedia.org/wiki/Windows-1252
This seems to be the answer: Windows-1252 includes äöüß etc., and even šžð, but NOT č.

Result: if the option “Embed standard fonts” is NOT checked, only characters from the Windows-1252 charset are exported correctly to the watermark.

-> Adapted summary.
Comment 7 Roman Eisele 2012-10-17 13:37:26 UTC
@ Andreas Mantke:

Hi Andreas,

IIRC you have implemented the Watermark option for PDF export, which appeared first in LibO 3.6. Thank you very much for this useful feature!

This is a bug report about some limitation of that feature: if one does *not* check the option “Embed standard fonts” in the PDF export dialog window, the Watermark export misses any characters which are not included in the Windows-1252 character set.

So here is my question for you:

Can we (e.g. you ;-) do anything about this problem? Is this a bug/suboptimal implementation in LibreOffice? Or is this a general PDF problem, which is due to some limit in Adobe Reader/PDF infrastructure (I mean, can the standard fonts, if not embedded, only be used for Windows-1252 characters)?

I ask you because I think you may know best about this sort of things ...

Thank you very much!
Comment 8 Adolfo Jayme 2013-09-02 01:31:26 UTC
The "Embed standard fonts" option has been removed from master as it's kind of nonsensical and can produce unexpected results (like this bug). LibreOffice's new approach is to always embed "standard" fonts. So this could be marked RESOLVED already.
Comment 9 miles 2013-09-27 10:26:01 UTC
So, what release version will ship with this bug solved (4.1.2.2 still has this option)? Thanks.
Comment 10 miles 2014-04-20 19:25:26 UTC
LibreOffice 4.2 does not have this problem anymore, so I am marking this as resolved.