Bug 55959 - Bullets in MS-format documents get misinterpreted
Summary: Bullets in MS-format documents get misinterpreted
Status: RESOLVED DUPLICATE of bug 50284
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
3.6.2.2 release
Hardware: Other Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-10-13 21:29 UTC by Martin Srebotnjak
Modified: 2013-11-16 16:18 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Original bullet list in ODT (8.92 KB, application/vnd.oasis.opendocument.text)
2012-10-13 21:29 UTC, Martin Srebotnjak
Details
Original ODT saved as RTF (4.55 KB, application/rtf)
2012-10-13 21:29 UTC, Martin Srebotnjak
Details
Original bullet list in ODT (8.92 KB, application/vnd.oasis.opendocument.text)
2012-10-13 21:30 UTC, Martin Srebotnjak
Details
Original ODT saved as DOCX (4.56 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2012-10-13 21:31 UTC, Martin Srebotnjak
Details
Saved DOCX opened and then saved as ODT (9.28 KB, application/vnd.oasis.opendocument.text)
2012-10-13 21:31 UTC, Martin Srebotnjak
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Srebotnjak 2012-10-13 21:29:08 UTC
Created attachment 68536 [details]
Original bullet list in ODT

I notice a strange reinterpretation of the list bullet from imported docx/rtf documents, they show up as a strange dingbat (or wingding, I am not sure) and not as a bullet like in the original MS tool. This might be connected to the codepage or the font codepage subset of the docx/rtf file, I am not sure.

I have attached 4 files:
- original.odt is a bulleted list with 3 items, the original.
- two files follow - saved versions of the original.odt in the RTF and DOCX format;
- the fourth one is the ODT as a saved result from opening the saved DOCX version in LP (the RTF version from previous step opens in LO as expected and does not contain misinterpreted bullets).
Comment 1 Martin Srebotnjak 2012-10-13 21:29:50 UTC
Created attachment 68537 [details]
Original ODT saved as RTF
Comment 2 Martin Srebotnjak 2012-10-13 21:30:45 UTC
Created attachment 68538 [details]
Original bullet list in ODT
Comment 3 Martin Srebotnjak 2012-10-13 21:31:12 UTC
Created attachment 68539 [details]
Original ODT saved as DOCX
Comment 4 Martin Srebotnjak 2012-10-13 21:31:49 UTC
Created attachment 68540 [details]
Saved DOCX opened and then saved as ODT
Comment 5 Martin Srebotnjak 2012-10-13 22:05:54 UTC
Just to let you know - my LO is in Slovenian, it has Slovenian language set as default language.
Comment 6 Martin Srebotnjak 2012-10-18 18:28:50 UTC
Probably this is a duplicate of bug 50284.
Can someone confirm, please?
Comment 7 Roman Eisele 2012-10-19 06:21:35 UTC
(In reply to comment #6)
> Probably this is a duplicate of bug 50284.
> Can someone confirm, please?

Yes, IMHO this is the same issue as bug 50284, therefore I mark it as a duplicate of the latter.

Nevertheless, thank you very much for your bug report! I hope that the additional duplicate increases the weight of bug 50284, so that we will get a fix for it some day ;-)

*** This bug has been marked as a duplicate of bug 50284 ***