Bug 56009 - FORMATTING: Objects anchored to cell wrongly positionned to A1
Summary: FORMATTING: Objects anchored to cell wrongly positionned to A1
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.5.7.2 release
Hardware: Other All
: medium normal
Assignee: Caolán McNamara
QA Contact:
URL:
Whiteboard: BSA target:3.5.8
Keywords:
Depends on:
Blocks: mab3.5
  Show dependency treegraph
 
Reported: 2012-10-15 16:45 UTC by Laurent BP
Modified: 2013-01-08 19:44 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
Test file to check position of chart (12.64 KB, application/vnd.oasis.opendocument.spreadsheet)
2012-10-15 19:39 UTC, Laurent BP
Details
Screenshot of the file correctly opened with LibO 3.5.6 (14.08 KB, image/png)
2012-10-15 19:42 UTC, Laurent BP
Details
Screenshot of the file wrongly opened with LibO 3.5.7RC1 (14.14 KB, image/png)
2012-10-15 19:43 UTC, Laurent BP
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Laurent BP 2012-10-15 16:45:52 UTC
Problem description: 

Steps to reproduce:
1. create a chart
2. place it anywhere but not in A1
3. anchor to cell
4. Save file
5. Reload file

Current behavior:
chart is replace at A1

Expected behavior:
chart should kept the same place

This bug was corrected for LibO 3.6.2
https://bugs.freedesktop.org/show_bug.cgi?id=54695
Patch should be back-ported to 3.5.7

Platform (if different from the browser): 
Win 7              
Browser: Mozilla/5.0 (Windows NT 6.1; rv:15.0) Gecko/20100101 Firefox/15.0.1
Comment 1 Laurent BP 2012-10-15 19:04:45 UTC
Confirmed on Win XP
Comment 2 Laurent BP 2012-10-15 19:37:35 UTC
The bug is already present is LibO 3.5.7 RC1 but NOT in LibO 3.5.6
Comment 3 Laurent BP 2012-10-15 19:39:45 UTC
Created attachment 68588 [details]
Test file to check position of chart

Test file with a chart positioned in C1
Comment 4 Laurent BP 2012-10-15 19:42:50 UTC
Created attachment 68589 [details]
Screenshot of the file correctly opened with LibO 3.5.6
Comment 5 Laurent BP 2012-10-15 19:43:41 UTC
Created attachment 68590 [details]
Screenshot of the file wrongly opened with LibO 3.5.7RC1
Comment 6 tommy27 2012-10-22 06:03:35 UTC
3.5.7 is already out and there will not probably be a 3.5.8 release (3.5.x life cicle is over)

since the bug is fixed in LibO 3.6.2 I suggest to upgrade to this or following 3.6.x branche releases.
Comment 7 Not Assigned 2012-11-12 12:32:35 UTC
Kohei Yoshida committed a patch related to this issue.
It has been pushed to "libreoffice-3-5":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7ba78c7712abb83f515e45a744786af45a7fbc64&g=libreoffice-3-5

Resolves: fdo#56009 fdo#54695 Calculate positions of cell-anchored objects


It will be available in LibreOffice 3.5.8.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 8 Caolán McNamara 2012-11-12 12:34:35 UTC
yeah, there probably won't be another 3.5 release, but I pushed it to that branch in case there is for some reason