Bug Hunting Session
Bug 56030 - Nudge distance could change with zoom level
Summary: Nudge distance could change with zoom level
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
3.5.6.2 release
Hardware: Other Linux (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-10-16 10:34 UTC by Paul Weaver
Modified: 2016-05-25 15:08 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Paul Weaver 2012-10-16 10:34:09 UTC
Impact:
When doing fine alignment work, it is currently hard to nudge objects using the arrow keys because the movement is too coarse.

Reproduction:
 - Create some small shapes that you want to arrange in a very specific way
 - Zoom in and try to move them into your desired arrangement using the arrow keys
 - Note that the shapes move quite a large amount (on the screen) when zoomed right in, and not very much (on the screen) when you zoom right out.
 - Tear hair out that you can't get fine enough control over the beautiful arrangement of your shapes!

Desired behaviour:
The distance a shape jumps should be in proportion with the zoom level (i.e. it should jump roughly the same distance on the screen at all times, not the same distance in the document). If this behaviour is already present, its effect is certainly not strong enough!
Comment 1 Heiko Tietze 2016-05-25 15:08:35 UTC
You may press the alt key in order to move the object in smaller steps (depending on the zoom level). Close this (old) ticket as WORKSFORME. Sorry for the latency.