Download it now!
Bug 56183 - [APPHANG][docx] [fileopen] Writer doesn't open large table
Summary: [APPHANG][docx] [fileopen] Writer doesn't open large table
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.2.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 76200 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-10-19 14:25 UTC by braeunig
Modified: 2015-08-25 15:40 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
docx document with a large table (306.11 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2012-10-19 14:25 UTC, braeunig
Details

Note You need to log in before you can comment on or make changes to this bug.
Description braeunig 2012-10-19 14:25:52 UTC
Created attachment 68798 [details]
docx document with a large table

I attached a docx document (created with Word 2003) which consists of one large table with some random text data of a few hundred sides. If tried to open this document with LibreOffice writer, writer runs indefinitely with 100% CPU. The same document saved as doc does open, still it needs some minutes to open.
Comment 1 Florian Reisinger 2013-04-21 06:53:36 UTC
Confirm with attached document, cot able to test with doc because Word 2010 crashes. Tested on Windows + Ubuntu with master
Comment 2 Tushar Bende 2014-04-04 14:18:16 UTC
*** Bug 76200 has been marked as a duplicate of this bug. ***
Comment 3 Timur 2015-01-26 12:34:56 UTC
I think this is "inherited".
Reproduced with LO 4.2.8 and 4.3.5 but behavior changed starting from LO 4.4.0: Writer doesn't hang but opens the DOCX file very slowly (takes 2 minutes for 321 pages). Working with this file is also slow.
I suggest this be renamed to "FILEOPEN: Writer extremely slow to open and handle specific DOCX".
Comment 4 Matthew Francis 2015-04-10 08:59:41 UTC
The original failure to open the file at all was fixed - if there's a remaining issue with performance then that's a separate bug. 

(Opening the file I get the following results:
- Mac Word 2011: 0:35s
- LO 4.4.0.3: 1:45s
Which is different, but not an order of magnitude different.)

On the basis that the original issue was solved, closing this bug.
-> Status: RESOLVED WORKSFORME