Download it now!
Bug 56431 - FORMATTING: Table of Contents ToC Tabulator formatted incorrectly in left columns
Summary: FORMATTING: Table of Contents ToC Tabulator formatted incorrectly in left col...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.3.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: TableofContents-Indexes
  Show dependency treegraph
 
Reported: 2012-10-26 15:52 UTC by Glutanimate
Modified: 2019-09-05 13:26 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample document with bug in action (deleted)
2012-10-26 15:52 UTC, Glutanimate
Details
Image of how the TOC is formatted on even-numbered pages (50.35 KB, image/png)
2012-10-26 15:53 UTC, Glutanimate
Details
Image of how the TOC is formatted on odd-numbered pages (51.94 KB, image/png)
2012-10-26 15:54 UTC, Glutanimate
Details
Sample document with bug in action (36.03 KB, application/vnd.oasis.opendocument.text)
2012-10-27 18:06 UTC, Glutanimate
Details
Sample document showcasing the effect of hanging indents (35.96 KB, application/vnd.oasis.opendocument.text)
2012-10-27 18:07 UTC, Glutanimate
Details
Sample document based an a stock template showcasing the same bug (20.45 KB, application/vnd.oasis.opendocument.text)
2012-10-30 09:11 UTC, Glutanimate
Details
Sample document with ToC edited (37.47 KB, application/vnd.oasis.opendocument.text)
2019-09-05 13:21 UTC, Timur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Glutanimate 2012-10-26 15:52:30 UTC
Created attachment 69117 [details]
Sample document with bug in action

Problem description: 

The rightmost tabulator in the left colunm of a two-column-design TOC is formatted incorrectly. This appears to happen on even-numbered pages only, even though all pages are set to the standard page style.

I supplied a sample file with a TOC. Additionally I provided two images that compare formatting between even-numbered and odd-numbered pages.
Comment 1 Glutanimate 2012-10-26 15:53:37 UTC
Created attachment 69118 [details]
Image of how the TOC is formatted on even-numbered pages
Comment 2 Glutanimate 2012-10-26 15:54:29 UTC
Created attachment 69119 [details]
Image of how the TOC is formatted on odd-numbered pages
Comment 3 Glutanimate 2012-10-26 16:00:28 UTC
I originally posted this bug on the openoffice.org forum: http://forum.openoffice.org/en/forum/viewtopic.php?f=7&t=57002
Comment 4 Glutanimate 2012-10-27 16:03:08 UTC Comment hidden (obsolete)
Comment 5 Glutanimate 2012-10-27 18:06:31 UTC
Created attachment 69162 [details]
Sample document with bug in action
Comment 6 Glutanimate 2012-10-27 18:07:36 UTC
Created attachment 69163 [details]
Sample document showcasing the effect of hanging indents

There seems to be a connection to hanging indents as enabling them causes the rightmost tab to disappear on all columns and pages. I attached a sample file with this effect in action.
Comment 7 Glutanimate 2012-10-30 09:11:15 UTC
Created attachment 69297 [details]
Sample document based an a stock template showcasing the same bug
Comment 8 peter Roots 2012-11-07 20:25:14 UTC
I have had a play around with this, after seeing it on the LO forum and can confirm the problem, both the the sample file and one I created for myself. (on LO 3.5.6 Fedora 17) I have just tested the example file on 3.5.7 and it shows the same behaviour
Comment 9 bfoman (inactive) 2013-03-04 13:32:44 UTC
Confirmed with:
LO 4.0.0.3
Build ID: own W7 debug build
Windows 7 Professional SP1 64 bit

Sample file's TOC rendered differently on even and odd pages (as on attached pictures by reporter).
Comment 10 Glutanimate 2013-04-21 20:58:56 UTC Comment hidden (obsolete)
Comment 11 Samuel Mehrbrodt (CIB) 2013-05-09 22:23:13 UTC
These dots in the TOC are one Tabstop formatted with dots.
Here the tabstops are generated: http://opengrok.libreoffice.org/xref/core/sw/source/core/doc/doctxm.cxx#1617

They are generated correctly, I just debugged this function. aToken has the right cTabFillChar etc, it's no difference to the other ones which are correctly displayed.

Don't know where the right place is to look at this.
Comment 12 QA Administrators 2015-03-04 02:22:27 UTC Comment hidden (obsolete)
Comment 13 Buovjaga 2015-03-24 13:32:32 UTC
(In reply to Glutanimate from comment #7)
> Created attachment 69297 [details]
> Sample document based an a stock template showcasing the same bug

Confirmed.

Win 7 Pro 64-bit, LibO Version: 4.4.1.2
Build ID: 45e2de17089c24a1fa810c8f975a7171ba4cd432
Locale: fi_FI
Comment 14 Robinson Tryon (qubit) 2015-05-26 03:27:06 UTC Comment hidden (obsolete)
Comment 15 QA Administrators 2016-09-20 09:46:09 UTC Comment hidden (obsolete)
Comment 16 Timur 2019-09-05 13:21:39 UTC
Created attachment 153918 [details]
Sample document with ToC edited
Comment 17 Timur 2019-09-05 13:26:55 UTC
I don't see the point of this bug. 
Is it to ask a solution for this attached Sample document from attachment 69162 [details] or report a general bug (but there's no steps and Expected/Experienced results)?
Now with LO 6.4+, attached Sample document was also wrong. 

I also attached an edited ODT with corrected ToC that looks fine to me. 
Generated ToC is also fine, so I don't know what led to bug. 

I reported or edited a number of ToC bugs like Bug 118960, bug 118962, bug 32360, bug 114773. 
I hope this one is covered by them, so I'll close. 
If I'm wrong, feel free to set back to New and explain what's at stake here that is not covered by others.