Bug 56944 - Extensionname: Zotero fields not appearing for old citations, only newly inserted ones connect
Summary: Extensionname: Zotero fields not appearing for old citations, only newly inse...
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Extensions (show other bugs)
Version:
(earliest affected)
3.5.4 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-10 07:14 UTC by Rich R
Modified: 2014-07-19 20:44 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
a document I am working on with cites that don't show. You will need to have zotero installed and open, either standalone or as firefox extension, and zotero libreoffice extension installed all from zotero.org (41.26 KB, application/vnd.oasis.opendocument.text)
2012-11-10 07:14 UTC, Rich R
Details
some cites show, some do not (43.83 KB, application/vnd.oasis.opendocument.text)
2012-12-14 11:34 UTC, Rich R
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rich R 2012-11-10 07:14:09 UTC
Created attachment 69853 [details]
a document I am working on with cites that don't show.  You will need to have zotero installed and open, either standalone or as firefox extension, and zotero libreoffice extension installed all from zotero.org

Problem description: 

Steps to reproduce:
1. update using apt-get upgrade
2. open a document with zotero citations in it. citations should show in gray but they do not, they show as normal text in both footnotes and parenthetical cites.
3. can add new citations to a document, but the old ones will no longer be seen and do not update: no connection to zotero except for newly entered citations.  
4. unzip odt file and view content.xml.  code for old citations appears in the document.  
5. open in a linux box that has not recently been updated and the citations reappear.  update that computer and repeat.  
6. ask for help at zotero forums, get told it is a problem with libreoffice "by definition" since it is the field codes not showing. 
7. Checked it on several computers in several locations and once updated they no longer connect to the zotero database properly.
The update for the laptop I am using now was from (1:3.5.3-0ubuntu1) to 1:3.5.4-0ubuntu1.1 in Linux mint 13 (maya/precise), but the same thing happened running Linux Mint debian (tracks testing) on both a 32 and a 64 bit machine.  

Current behavior:
zotero fields not showing up in gray or connecting to zotero dbase, only new citations recognized and in gray

Expected behavior:
previous as well as new zotero citations and bibliographies highlighted in gray and connected to zotero database

plz help, as this affects two books and many articles and thousands of hours of work!

Platform (if different from the browser): 
Linux mint 12 (same problem on Linux Mint debian, which tracks a modified version of debian testing.)  
              
Browser: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:16.0) Gecko/20100101 Firefox/16.0
Comment 1 Rich R 2012-12-14 11:07:59 UTC
update:
Was running openjdk/icedtea.  uninstalled and replaced with oracle java 7, no luck.  switched to oracle jave 6 and updated libreoffice to 3.6 and most of my citations seem to be back, but some docs, like the new one I am attaching, show only some of the citation fields in gray, leaving the rest as plain text even though the field codes are still in the document.
Comment 2 Rich R 2012-12-14 11:34:27 UTC
Created attachment 71495 [details]
some cites show, some do not

field codes do not show in my libreoffice 3.6 install untill ftnt 9, then 18, 19, 27, and some more show.  You must save as a new doc, since the field codes will not show at all if the doc is read-only.
Comment 3 Rich R 2012-12-14 11:44:55 UTC
Neither zotero nor its libreoffice plugin need to be installed to see the zotero field codes according to Dan Stillman, one of the Zotero devs. see http://forums.zotero.org/discussion/25754/no-field-codes-in-any-of-my-documents-anymore-libreofficelinux-mint-lmde/#Comment_137518 entry of Nov 11th 2012
Comment 4 tommy27 2014-07-19 11:57:35 UTC
is issue still reproducible with current stable LibO 4.2.5.2?
Comment 5 Joel Madero 2014-07-19 20:44:24 UTC
This should be reported to zotero.org not LibreOffice - we're not responsible for maintaining third party extensions, it is their job to keep up with our code. Marking as NOTOURBUG