Bug Hunting Session
Bug 57011 - Formatting: spell checker jumps to cursor after closing and doesn't stay at the last checked word
Summary: Formatting: spell checker jumps to cursor after closing and doesn't stay at t...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Spell-Checking Writer-View-Jumps
  Show dependency treegraph
 
Reported: 2012-11-12 12:13 UTC by Markus Grob
Modified: 2018-09-27 20:38 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Markus Grob 2012-11-12 12:13:33 UTC
If I check the document and close the dialog manually, then it is normally, because I like to change things around the last checked word.
But now I have to jump from the cursor back to the word and after this, I can edit it.
Couldn't you change it, that if the check is stopped, that the focus will stay at the last checked word.

Greetings from Switzerland, Markus
Comment 1 Florian Reisinger 2013-04-21 07:03:16 UTC
A testing document please
Comment 2 Markus Grob 2013-05-05 11:39:29 UTC
I think, you don't need a document. I hope, if I describe it right, you will understand, what my problem is.

If I work with a big document and have the cursor on the first page and start the spellchecker, the document scrolls down, while I'm correcting the words or committing them into the checker.

Now my case starts:

After 5 sites I see an error in the document and will correct it outside the spellchecker. For this, I stop the spellchecker, but the document don't stops there, it scolls back to where it starts (first page).

After this, I have to scroll down and tries to find the error again.

-> I prefer, that the spellchecker doesn't scroll back to the cursor position, but stays at the given document position, after closing it.

Was this understandable?

Example:

text
<-Cursor      <---------------- (jumps back after closing)
text                           |
...lot of text...              |
... 4 pages with text ...      |
...                            |
error <- spellchecker is here--|
Comment 3 Markus Grob 2013-10-08 16:14:16 UTC

*** This bug has been marked as a duplicate of bug 34425 ***
Comment 4 Winfried Donkers (retired) 2013-10-09 07:51:22 UTC
(In reply to comment #3)
> 
> *** This bug has been marked as a duplicate of bug 34425 ***

@Markus: bug 34425 is a fixed bug about buttons. I suspect you marked the wrong bug...
Comment 5 Markus Grob 2013-10-09 10:08:53 UTC
OK. Now I have seen the Problem. The same Bug ist also registered in AOO: Apache OpenOffice (AOO) Bugzilla – Bug 34425. Because of this I have closed this bug. The problem is, that same bugs are older then the split to AOO and LO.

I hope, the bug will be closed (in both versions ;-) ).

Markus
Comment 6 Joel Madero 2014-11-06 18:03:35 UTC
needs to be confirmed by QA - moving to UNCONFIRMED. Thanks
Comment 7 A (Andy) 2014-11-06 19:33:25 UTC
Reproducible with LO 4.3.3.2, Win 8.1.

Steps Done:
1. Open a document with several pages in WRITER
2. Put the cursor at the beginning of the document
3. Go to TOOLS -> SPELLING AND GRAMMAR
4. When you arrive at a mistake after a few pages press the Close button, because you want to change there something manually

Result:
After pressing the Close button the document scrolls up to the first page.  To correct the mistake you have then again to scroll down.
Comment 8 Thomas Lendo 2017-03-11 21:53:20 UTC
This is an old bug from OOo times, first reported in 2004 and it still exists in LibO 5.3.0.3.

I think Stefan Baltzer made good suggestions in comment 2 of the OOo issue. I will quote his 4 points - personally I would prefer no. 4 which wouldn't require a UI change:

------
(1) Introducing a "break" button in the spellcheck dialog.

(2) Yet-another-option for the spellchecker: "Place the cursor where the spellchecker was closed".

(3) Change behavior (no UI change): When the user clicks "Undo" and "Close", only THEN the cursor goes to the last position where a change took place.

(4) Change behavior (no UI change): When the user clicks beside the spellcheck dialog and then closes it, the cursor stays there (currently it is jumping back to where spellcheck was started).
------