Download it now!
Bug 57012 - EDITING: wmf-files does not keep side ration
Summary: EDITING: wmf-files does not keep side ration
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.5.7.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-12 12:20 UTC by bugquestcontri
Modified: 2015-03-07 11:42 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Draw file containing wmf-file, screenshot and explanation (33.87 KB, application/vnd.oasis.opendocument.graphics)
2012-11-12 12:20 UTC, bugquestcontri
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bugquestcontri 2012-11-12 12:20:23 UTC
Created attachment 69940 [details]
Draw file containing wmf-file, screenshot and explanation

Problem description: 
A wmf-format image copied into Impress and flagging Keep Ratio does not keep the ration.

In the attached Draw-file there is wmf-file included. Also in Draw the ratio is not kept.

A screenshot from Impress is included in the Draw file

3 other wmf-files behave the same. Tested only in Impress

Steps to reproduce:
1. Paste a wmf-file into Impress
2. Set Keep Ration
3. Pull a handle into 1 direction
4. Side ration will change

Current behavior:
Side ration changes despite "Keep Ratio" setting

Expected behavior:
Side ratio stays constant when flag is set.

Platform (if different from the browser):  XP / SP3
              
Browser: Mozilla/5.0 (Windows NT 5.1; rv:16.0) Gecko/20100101 Firefox/16.0

I can be contacted
Comment 1 A (Andy) 2013-03-16 13:45:02 UTC
reproducible with LO 4.0.1.2 (Win7 Home, 64bit)

I would agree that if I set KEEP RATIO and then if I change the size of the picture the ratio should be kept.
The same happens in DRAW.
Comment 2 QA Administrators 2015-02-19 15:32:46 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.0.3 or later): https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior

If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

Thank you for your help!

-- The LibreOffice QA Team
This NEW Message was generated on: 2015-02-19
Comment 3 Buovjaga 2015-03-07 11:42:57 UTC
Not reproduced anymore -> WFM.

Win 7 Pro 64-bit, LibO Version: 4.4.1.2
Build ID: 45e2de17089c24a1fa810c8f975a7171ba4cd432
Locale: fi_FI