Download it now!
Bug 57020 - Command line switch --minimize doesn't work as announced
Summary: Command line switch --minimize doesn't work as announced
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
3.6.3.2 release
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-12 15:49 UTC by Pedro
Modified: 2016-09-15 12:08 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
stampa dell'errore (148.88 KB, application/pdf)
2013-11-27 19:58 UTC, Massimo Pagliai
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pedro 2012-11-12 15:49:09 UTC
According to
http://help.libreoffice.org/Common/Starting_the_Software_With_Parameters

executing soffice.exe --minimize will "Starts minimized. The splash screen is not displayed."

Indeed the splash screen is not displayed but the program window opens normally (i.e. not minimized to the taskbar)
Comment 1 Pedro 2013-06-08 23:38:43 UTC
Correction: the command is soffice.exe --minimized (it was a typo in the bug report not in the procedure)

This still applies to LO 4.0.3.3 under Windows XP x86 (didn't test other Win versions)
Comment 2 Massimo Pagliai 2013-11-27 19:58:33 UTC
Created attachment 89916 [details]
stampa dell'errore
Comment 3 Pedro 2013-11-27 22:45:11 UTC
(In reply to comment #2)
> Created attachment 89916 [details]
> stampa dell'errore

I think this screenshot was added to the wrong bug.

In any case the bug still occurs with Version: 4.1.3.2
Build ID: 70feb7d99726f064edab4605a8ab840c50ec57a
Comment 4 Robinson Tryon (qubit) 2014-02-04 14:45:20 UTC
(In reply to comment #0)
> According to
> http://help.libreoffice.org/Common/Starting_the_Software_With_Parameters
> 
> executing soffice.exe --minimize will "Starts minimized. The splash screen
> is not displayed."

According to the man page for 3.5.7:

      --minimized
              Keeps the splash screen minimized.

Per current sources:
http://opengrok.libreoffice.org/xref/core/sysui/desktop/man/libreoffice.1

    --minimized Keeps the splash screen minimized. 

> Indeed the splash screen is not displayed but the program window opens
> normally (i.e. not minimized to the taskbar)

It looks like the Online Help Wiki might incorrectly describe expected behavior. Punting this over to Documentation for review.

Status -> NEW
Comment 5 Pedro 2014-02-04 16:44:06 UTC
@Qubit, "Keeps the splash screen minimized" doesn't make any sense. It's the groklaw description that is wrong.

In any case you are missing the point: this is NOT a documentation problem! --minimized simply doesn't work! NOTHING is minimized!
Comment 6 Robinson Tryon (qubit) 2014-02-04 19:22:10 UTC
(In reply to comment #5)
> @Qubit, "Keeps the splash screen minimized" doesn't make any sense. It's the
> groklaw description that is wrong.

The description could be better-worded (perhaps "Do not show the splash screen"), but it does describe a real phenomenon. 

> In any case you are missing the point: this is NOT a documentation problem!
> --minimized simply doesn't work! NOTHING is minimized!

Try comparing the result of the following two commands:

./soffice
./soffice --minimized

Note that in the first case you will see a splash screen appear; in the second case, you will see no splash screen.
Comment 7 Pedro 2014-02-04 22:03:54 UTC
(In reply to comment #6)
> The description could be better-worded (perhaps "Do not show the splash
> screen"), but it does describe a real phenomenon. 

It is simply wrong. The start screen is NOT minimized (otherwise it would show as a minimized task) it simply is not DISPLAYED. The original message (see Comment #1) was correct.

The problem still remains that LO is NOT started minimized.
 
> Note that in the first case you will see a splash screen appear; in the
> second case, you will see no splash screen.

I know that. See Comment #1 from November 2012...
Comment 8 Joel Madero 2015-05-02 15:44:30 UTC Comment hidden (obsolete)
Comment 9 Pedro 2015-05-02 22:00:48 UTC
Bug still present in version 4.4.3.2 under Windows XP Pro x86 SP3 and Windows 7 Pro x64 SP1.

And is also present in a parallel install of Version: 5.0.0.0.alpha1+ (x64)
Build ID: 0cd88d27ecd87c8c5791418bcac6ab1684ece74a
TinderBox: Win-x86_64@42, Branch:master, Time: 2015-04-30_01:15:32
Locale: pt_PT
under Windows 7 Pro x64 SP1
Comment 10 Xisco Faulí 2016-09-15 12:08:11 UTC
I can't reproduce it in

Version: 5.2.0.0.alpha0+
Build ID: ea7b57272cea8d74d0d47ee3dddd019f256f80f2
CPU Threads: 1; OS Version: Windows 6.1; UI Render: default; 
Locale: es-ES (es_ES)

Thus, close it as RESOLVED WORKSFORME