Bug 57104 - UI: UI fails to implement initial Alt-key shortcuts to top-level Libre Office menu items
Summary: UI: UI fails to implement initial Alt-key shortcuts to top-level Libre Office...
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.2.2 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-14 01:31 UTC by bbq
Modified: 2013-05-21 18:39 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bbq 2012-11-14 01:31:24 UTC
Problem description: 

Steps to reproduce:
1. Press Alt-F
2. Fail to see File menu items expand
3. Use mouse to accomplish same while cursing Apple-centric testing...

Current behavior:  No UI access to top-level menu when installed in Ubuntu 12.10

Expected behavior:  Alt-F would open File menu items for deeper selection

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.19 (KHTML, like Gecko) Chrome/25.0.1323.1 Safari/537.19
Comment 1 Max Barry 2012-12-05 01:37:43 UTC
Confirmed here after upgrading to Ubuntu 12.10, LibreOffice 3.6.2.2. None of the Alt+key combinations that are supposed to open top-level menus do anything.
Comment 2 Robinson Tryon (qubit) 2013-03-19 04:07:07 UTC
Looks like the same symptoms as described here:
http://ask.libreoffice.org/en/question/14003/menu-shortcuts-in-lo-4/

Works for me in (LO 4.0.0.3 + Ubuntu 12.04.2), however does NOT work for Pansmanser:

---
I am running LO 4.0.1.1 on Ubuntu 12.04 (32 bit Kernel Linux 3.2.0-38-generic-pae.)

The top menubar does not have underlined letters, and none of the former shortcut keys work.
---

There is also another error on Pansmanser's system (unknown if related):

---
I would also like to be able switch off the global menu. This version of LibreOffice seems to ignore the switch in SystemSettings-Unsettings-Windows.
---
Comment 3 Cor Nouws 2013-04-27 21:10:46 UTC
isn't this a problem with Unity?
I never have problems with 'parallel' installed versions of LibreOffice (thus without sys integration).
Comment 4 Urmas 2013-04-28 00:40:59 UTC
Into a Loonix bin.
Comment 5 PawelK 2013-05-14 13:33:56 UTC
It does not work for me as well. 

Pressing "alt+f" does not open menu. Also in menu bar there is no shurtcuts indicator ("there is File" and not "_F_ile"). 

LibreOffice Version 4.0.2.2 (Build ID: 400m0(Build:2))
x86_64 GNU/Linux, ubuntu 12.04
Comment 6 ign_christian 2013-05-15 09:37:35 UTC
Not reproducible on LO 3.6.6.2, installed from LibreOffice ppa (Ubuntu 12.04.2 32bit, kernel 3.2.0-41-generic-pae), Alt-F works as expected.

As Cor Nouws said, probably it's related to Unity. Or related with any tweaking utility?
Comment 7 ign_christian 2013-05-15 09:52:57 UTC
(In reply to comment #6)
> Not reproducible on LO 3.6.6.2, installed from LibreOffice ppa (Ubuntu
> 12.04.2 32bit, kernel 3.2.0-41-generic-pae), Alt-F works as expected.
> 
> As Cor Nouws said, probably it's related to Unity. Or related with any
> tweaking utility?


I can confirm that Alt-F not functioning when I enable Unity. Result on comment #6 is happen because I'm using Cairo-Dock (Gnome+Effects) & disable Unity.

Could you test that with Unity disabled?
Comment 8 Tom Colley 2013-05-21 02:57:43 UTC
I am experiencing the same issue with LibreOffice/Unity. I use two installations of LibreOffice 4.0.x:

1) Windows Vista Enterprise - LibreOffice 4.0.2.2 - this installation allows the menu shortcut keys (eg. Alt + F --> Open File Menu)

2) Ubuntu 13.04 - LibreOffice 4.0.x - this installation DOES NOT ALLOW the menu shortcut keys 

This bug also appears (and has been better investigated) at https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/739184.

It appears to be an integration issue with Unity/Ubuntu and a workaround (with limitations) is offered:

 'WORKAROUND: Disable the global menu by removing the package "libreoffice-gtk".'
Comment 9 Björn Michaelsen 2013-05-21 18:39:44 UTC
closing as NOTOURBUG here for now as per:

 https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/739184/comments/60