Bug 57225 - : Wrong Menu Link: Language Selection
Summary: : Wrong Menu Link: Language Selection
Status: RESOLVED DUPLICATE of bug 39793
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.3.2 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-17 13:43 UTC by A (Andy)
Modified: 2012-11-17 20:36 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description A (Andy) 2012-11-17 13:43:09 UTC
Problem description: 
If you want to choose another language for the spell check for a specific selection or paragraph you will possibly by selecting the corresponding menu item not get to the correct dialogue window.

Steps to reproduce:
1. Open WRITER
2. Type any text
3. Select this text
3. Go to TOOLS -> LANGUAGE -> FOR SELECTION or FOR PARAGRAPH and then MORE

Current behavior:
You will possibly not get to the correct section FONT of the dialogue window CHARACTER.
Remark: It could be that you will get to the correct section FONT, in this case please go to any other section and press OK and then try to open the spell check selection again.

Expected behavior:
You should always get to a correct dialogue window (e.g. FONT), where you can choose another specific language.
In addition it is a little bit confusing, that if you choose FOR ALL TEXT instead of FOR SELECTION or FOR PARAGRAPH you will get to another dialogue window. For an intuitive handling from the point of view of a user it is probably better to have one dialogue window, because it seemed not possible to understand why you will in the case of FOR ALL TEXT get to another dialogue window. It seemed not to be consistent.
Comment 1 manj_k 2012-11-17 20:36:30 UTC
Already reported: Bug 39793 - UI · FORMATTING: 'Set Language for Paragraph/Selection > More...' should always open the 'Font' tab (dialog 'Character'.

(See also, wrt "For all Text": Bug 37919 - Clicking "more" on the Language Section in Writer at the bottom bar opens up the wrong Dialog Window.)

*** This bug has been marked as a duplicate of bug 39793 ***