Bug 57249 - labelling axes with superscript is not formatting properly
Summary: labelling axes with superscript is not formatting properly
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: Other Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-18 14:29 UTC by Bernd Kloss
Modified: 2015-04-19 13:53 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
labelling of axes with superscript bad format (18.92 KB, application/vnd.oasis.opendocument.text)
2012-11-18 14:29 UTC, Bernd Kloss
Details
labelling axes with superscript produces bad format (18.28 KB, application/vnd.oasis.opendocument.text)
2012-11-18 14:44 UTC, Bernd Kloss
Details
Screenshot shows that the wrong font is used for superscript text in axis labels (154.56 KB, image/png)
2012-11-18 15:52 UTC, Roman Eisele
Details
A detail screenshot, showing the font substitution better (116.74 KB, image/png)
2012-11-18 16:16 UTC, Roman Eisele
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bernd Kloss 2012-11-18 14:29:44 UTC
Created attachment 70215 [details]
labelling of axes with superscript bad format

Both WRITER and CALC 
graph from chart and labelling axes with superscript like 10 power -9
Type of character is lucida grande which cannot be changed

Inserting superscript for exponents produces different types of characters
See attachment
Comment 1 Bernd Kloss 2012-11-18 14:44:49 UTC
Created attachment 70217 [details]
labelling axes with superscript produces bad format
Comment 2 Roman Eisele 2012-11-18 15:52:43 UTC
Created attachment 70218 [details]
Screenshot shows that the wrong font is used for superscript text in axis labels
Comment 3 Roman Eisele 2012-11-18 16:10:32 UTC
Thank you very much for your bug report!

REPRODUCIBLE with LibreOffice 3.6.4.1 (Build ID: a9a0717), German langpack installed, on Mac OS X 10.6.8 (Intel). As my screenshot shows, LibreOffice uses for the superscript figures and letters in the axis labels another font (family) than elsewhere in the chart and axis labels.

While the font family used elsewhere in the chart is Lucida Grande (a Mac OS X system font), the superscript figures appear
* in Lucida Grande: only superscript 2 and 3 
* in some other font (in my case: Alegreya): superscript 0, 4, 5, 6, 7, 8, 9, i.

The difference between these two groups of figures is that the superscript 2 and 3 are part of the basic ISO Latin 1 character set, and therefore are located in the “Latin-1 Supplement” section of Unicode at U+00B2 and U+00B3, but the other “superscript figures and the superscript i are located in the “Superscript and Subscript” Unicode section at U+2070 and following.

It seems that LibreOffice takes the superscript 2 and 3 from the main text font (here: Lucida Grande), but what regards the extended superscript letters (which are missing from many simple fonts) it searches for another font which contains these special characters, and then takes the glyphes for these letters from the 1st font which contains glyphs for them -- in my case, this is Alegreya.

This behaviour would be entierly correct *if* the extended superscript letters 0, 4, ..., 9, i would be missing from Lucida Grande, just like they are missing from many simple fonts. Then LibreOffice would *need* to take these letters from some other font. But -- and this is IMHO the real bug -- Lucida Grande *does* actually contain glyphs for the superscript 0, 4, ...., 9 and i. So LibreOffice does change the font without any necessity. And this is a bug.
Comment 4 Bernd Kloss 2012-11-18 16:16:02 UTC
Thank you for your quick response.

The character "1" is also not correct. The fontset Lucida Grande produces "i" instead of "1". Probably due to missing characters in fontset as you described above.
Comment 5 Roman Eisele 2012-11-18 16:16:08 UTC
Created attachment 70220 [details]
A detail screenshot, showing the font substitution better
Comment 6 Roman Eisele 2012-11-18 16:19:18 UTC
About versions:

The bug is still REPRODUCIBLE with a current master build, e.g.
LOdev 4.0.0.0.alpha0+ (Build ID: ed8067; pull time: 2012-11-15 03:54:19).

The bug is already REPRODUCIBLE with identical results in
LibreOffice 3.3.0, OOO330m19 (Build:6), tag libreoffice-3.3.0.4.
Probably inherited from OOo (or GoOO).
→ Adapting Version field to the first version which is known to contain the bug
(as usual).
Comment 7 Roman Eisele 2012-11-20 18:05:51 UTC
(In reply to comment #4)
> The character "1" is also not correct. The fontset Lucida Grande produces
> "i" instead of "1".

The question if the superscript “i” instead of “1” is a bug or not, depends on how you entered the axis labels. U+2071 is correctly a superscript i (not 1), the superscript i is at U+0089, and if I manually insert U+0089 into the label text, it correctly remains a superscript 1 in Lucida Grande font.

So, how did you enter the axis labels text?
Comment 8 Bernd Kloss 2012-11-20 20:44:12 UTC
At the shown position of the cursor, I would have expected a ''1''.


http://dl.dropbox.com/u/16673743/bug_57249.odt

Did you get the sample?
My MAc uses other replacement characters than yours, so the exponents look terrible.

Regards 
Bernd

Am 20.11.2012 um 19:05 schrieb bugzilla-daemon@freedesktop.org:

> 
> Comment # 7 on bug 57249 from Roman Eisele
> (In reply to comment #4)
> > The character "1" is also not correct. The fontset Lucida Grande produces
> > "i" instead of "1".
> 
> The question if the superscript “i” instead of “1” is a bug or not, depends on
> how you entered the axis labels. U+2071 is correctly a superscript i (not 1),
> the superscript i is at U+0089, and if I manually insert U+0089 into the label
> text, it correctly remains a superscript 1 in Lucida Grande font.
> 
> So, how did you enter the axis labels text?
> 
> You are receiving this mail because:
> You reported the bug.
Comment 9 QA Administrators 2015-04-19 03:20:39 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   *Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1 or later)
   https://www.libreoffice.org/download/

   *If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
   *If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   *Update the version field
   *Reply via email (please reply directly on the bug tracker)
   *Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 
3. Leave a comment with your results. 
4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-04-18
Comment 10 Bernd Kloss 2015-04-19 13:53:58 UTC
LO 4.3.6.2 (latest version for mac by 2015-04-19)
OS X 10.10.3

Superscript 123 (U+00B9; 00B2; 00B3) correct
Negative superscript using U+207B acceptable


Thank You!

Regards 
Bernd Kloss