Bug 57364 - Writer, Calc, and Impress CRASH when saving
Summary: Writer, Calc, and Impress CRASH when saving
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.5.4 release
Hardware: x86 (IA32) Linux (All)
: medium critical
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-21 11:03 UTC by tobias.unsleber
Modified: 2012-11-22 13:37 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
cpuinfo/meminfo/dpkg -l and lowriter --strace output (850.00 KB, application/x-tar)
2012-11-21 11:03 UTC, tobias.unsleber
Details

Note You need to log in before you can comment on or make changes to this bug.
Description tobias.unsleber 2012-11-21 11:03:02 UTC
Created attachment 70361 [details]
cpuinfo/meminfo/dpkg -l and lowriter --strace output

Problem description: 

Steps to reproduce:
1. Start LO-Writer
2. File -> New (Text document/Spreadsheet/Presentation)
3. File -> Save as...
4. Select Name of File to save
5. Save

LO-Writer/Spreadsheat/Presenter CRASHES after pushing the SAVE Button

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:16.0) Gecko/20100101 Firefox/16.0

$ uname -a
Linux myhost 3.2.0-33-generic-pae #52-Ubuntu SMP Thu Oct 18 16:39:21 UTC 2012 i686 i686 i386 GNU/Linux

Base System: Ubuntu 12.04
Desktop Environment: Trinity 3.5.13.1

***System Output on Console ***

(soffice:3187): Gtk-CRITICAL **: IA__gtk_entry_get_text: assertion `GTK_IS_ENTRY (entry)' failed
KCrash: crashing... crashRecursionCounter = 2
KCrash: Application Name = gtk-qt-application path = <unknown> pid = 3187
Comment 1 tobias.unsleber 2012-11-21 11:09:41 UTC
Possibly related bug reports in Ubuntu Launchpad Bugtracker:

https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/1076944
https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/1070939
Comment 2 Julien Nabet 2012-11-21 22:54:15 UTC
Did you try to reproduce it after having rename your LO directory profile? (see http://wiki.documentfoundation.org/UserProfile)

Did you install any specific LO extensions?

Could you give a try to a newer LO version? (see https://launchpad.net/~libreoffice/+archive/ppa)
Comment 3 Roman Eisele 2012-11-22 07:09:40 UTC
(Not a bug with BASIC, the programming/macro language, but a basic LibreOffice bug, therefore adjusted Component; set Platform according to comment #0; “normalized” Summary.)
Comment 4 tobias.unsleber 2012-11-22 13:19:01 UTC
This problem seems to be related to my a bit more than ususal non-standard-system:

I got this error now in firefox too when downloading something(So in connection with the same save/save-as dialog). Same error message in console. Maybe there's something wrong with a specific library.

I don't know if this is something important to libreoffice itself or just to my specific System.

---

> Did you try to reproduce it after having rename your LO directory profile? (see 
> http://wiki.documentfoundation.org/UserProfile)

renamed my profile folders. Nothing changed. 

> Did you install any specific LO extensions?

No.
Comment 5 Julien Nabet 2012-11-22 13:24:58 UTC
Would you have another machine to confirm this bug?
Can you create a simple text file in your home?
If you can't, did you check the available space for each partition?
Comment 6 Julien Nabet 2012-11-22 13:37:38 UTC
Sorry, my previous was a wrong hint.
However, I found this link:
http://comments.gmane.org/gmane.comp.desktop.trinity.user/2727
Hope it helps.

Anyway, not a LibreOffice bug obviously.