Bug Hunting Session
Bug 57370 - [ACCESSIBILITY] Panel 'Places' in LibreOffice file dialog is not in TAB-order - can't use it with the key board
Summary: [ACCESSIBILITY] Panel 'Places' in LibreOffice file dialog is not in TAB-order...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
3.6.0.4 release
Hardware: Other All
: medium normal
Assignee: Szymon Kłos
URL:
Whiteboard: target:5.1.0 target:5.0.3
Keywords: accessibility
Depends on:
Blocks:
 
Reported: 2012-11-21 14:03 UTC by Cor Nouws
Modified: 2016-09-16 11:41 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cor Nouws 2012-11-21 14:03:01 UTC
Use the LibreOffice OpenSave dialog (Tools Options GEneral)
In the dialog you can add places ( \O/ )
However, using TAB does not lead me to that pane :-\
Comment 1 Buovjaga 2014-11-09 19:09:53 UTC
Confirmed.

Win 7 64-bit Version: 4.4.0.0.alpha2+
Build ID: 9229170920ab770624415c4330da57af5b1b5398
TinderBox: Win-x86@39, Branch:master, Time: 2014-11-09_03:16:43
Comment 2 V Stuart Foote 2015-07-19 18:07:24 UTC
@Cor, *,

Still valid?

I'm on Windows 7 sp1, 64-bit en-US with
Version: 5.1.0.0.alpha1+ (x64)
Build ID: 14257152b19c08618a107c6eb0f684de11483da8
TinderBox: Win-x86_64@62-TDF, Branch:MASTER, Time: 2015-07-17_03:23:36
Locale: en-US (en_US)

Keyboard navigation to all elements of the LibreOffice Open/Save dialog (set from Tools -> Options -> General: "Use LibreOffice Dialogs") is working correctly on Windows builds.
Comment 3 Szymon Kłos 2015-07-19 19:40:31 UTC
I'm on Linux 32-bit (Fedora 21) - master branch (build from yesterday)

The order of focus when I'm switching controls with TAB key:
'Create New Folder' button -> file list -> file name edit field

The places with add and delete buttons were omitted.
Comment 4 V Stuart Foote 2015-07-19 21:22:21 UTC
OK, see that there is an issue.  Is it becaurse there is a mix of .UI and SRC in the "LibreOffice dialogs" dialog--aka. the filepicker? 

Most of the panel is configured and keyboard navigated as .UI as in http://opengrok.libreoffice.org/xref/core/fpicker/uiconfig/ui/

but the PlacesListBox is still implemented as source.
http://opengrok.libreoffice.org/xref/core/fpicker/source/office/PlacesListBox.cxx

Believe that the PlaceListBox (i.e. _pPlaces), is not defined in a .UI GTK box. So, it is OK with mouse and cursor navigation, but with dialog partially converted to .UI its widget can't be reached with keyboard only.
Comment 5 Szymon Kłos 2015-07-20 06:38:31 UTC
PlaceListBox is inserted into custom container, which inherits from vcl::Window), because of using splitter to resize it. We must manually manage focus for this container.

Now SvtFileView always gets focus, if container gets focus.
http://opengrok.libreoffice.org/xref/core/fpicker/source/office/iodlg.cxx#406

Yesterday I submitted the patch resolving this bug:
https://gerrit.libreoffice.org/#/c/17192/
Comment 6 Cor Nouws 2015-08-10 15:08:18 UTC
(In reply to Szymon Kłos from comment #5)

> Yesterday I submitted the patch resolving this bug:
> https://gerrit.libreoffice.org/#/c/17192/

Thanks! Can you push it too?
Comment 7 V Stuart Foote 2015-08-10 15:37:29 UTC
(In reply to Cor Nouws from comment #6)
> Thanks! Can you push it too?

Looks like it was failing Jenkins builds, so probably needs another round, and a closer look from other Devs.
Comment 8 Cor Nouws 2015-08-10 18:39:07 UTC
(In reply to V Stuart Foote from comment #7)
> Looks like it was failing Jenkins builds, so probably needs another round,
> and a closer look from other Devs.

I've seen strange fails from Jenkins for a non brainer UI change myself, that got included straight away, so not sure about that ;)
Comment 9 Buovjaga 2015-08-10 19:53:34 UTC
(In reply to Cor Nouws from comment #8)
> (In reply to V Stuart Foote from comment #7)
> > Looks like it was failing Jenkins builds, so probably needs another round,
> > and a closer look from other Devs.
> 
> I've seen strange fails from Jenkins for a non brainer UI change myself,
> that got included straight away, so not sure about that ;)

I have sometimes wondered out loud about Jenkins fails in gerrit submissions and was told it was a coincidence: there was some other mistake blocking the build for a whole day or something similar.
Comment 10 Commit Notification 2015-09-03 08:22:36 UTC
Szymon Kłos committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7088dadc52d56e56aa674c95673a3f83cf4e1ab3

tdf#57370 : 'Places' in the LibreOffice file dialog is inaccessible

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 11 Cor Nouws 2015-09-30 17:47:08 UTC
Szymon, pushing to 5.0 branch would be lovely :)
Comment 12 Szymon Kłos 2015-10-01 10:24:44 UTC
Submitted to the gerrit :)
Comment 13 Commit Notification 2015-10-01 14:08:27 UTC
Szymon Kłos committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0f8784572120f0a637aa0f1250e45e04f446f287&h=libreoffice-5-0

tdf#57370 : 'Places' in the LibreOffice file dialog is inaccessible

It will be available in 5.0.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 14 V Stuart Foote 2015-10-01 15:25:26 UTC
@Szymon, Caolán, *

Testing this on Windows 10 Pro 64-bit en-US with current 32-bit master
Version: 5.1.0.0.alpha1+
Build ID: 25de5cfa43b2b1cb7d7214470acc7719839e13fe
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-10-01_08:49:54
Locale: en-US (en_US)

We now have keyboard navigation of focus into the PlaceListBox in the IO Dialog,  and we can reach each button widget with Tab and Cursor movement, so can add/remove directories from the PlaceList. Unfortunately we are unable to actually change into the selected directory using keyboard.

The desired directory can be highlighted in the PlaceListBox -- but then no Keyboard combination actually updates the dialog to change the listing into that directory.

Presently, the "Enter" key activates the dialog's Open button (which has nothing selected).

So, a mouse click on the highlighted directory in the list is still required to make the change.
Comment 15 Szymon Kłos 2015-10-01 17:45:36 UTC
I've fixed this. Place will be opened after pressing Enter. Patch is waiting for review.
Comment 16 Commit Notification 2015-10-02 10:45:26 UTC
Szymon Kłos committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=39a438dec58f0502a45cccbbc5257ae47e74df68

tdf#57370 : Open place after pressing 'Enter'

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 17 Commit Notification 2015-10-02 10:45:31 UTC
Szymon Kłos committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7dd8483362cf0ef102363204dd2235246400d96a&h=libreoffice-5-0

tdf#57370 : Open place after pressing 'Enter'

It will be available in 5.0.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 18 Robinson Tryon (qubit) 2015-12-10 03:37:40 UTC Comment hidden (obsolete)
Comment 19 Xisco Faulí 2016-09-15 22:25:13 UTC
Hello,
Is this bug fixed?
If so, could you please close it as RESOLVED FIXED?