Download it now!
Bug 57430 - Writer: "Additional formats" not available for "insert page number" but for Date field - Help is not clear
Summary: Writer: "Additional formats" not available for "insert page number" but for D...
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-22 20:22 UTC by peter Roots
Modified: 2016-05-23 06:26 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description peter Roots 2012-11-22 20:22:00 UTC
Insert>Fields>Other>Document>Page>Page Numbers
There is a list of available formats for the page numbers.
According to the help file :

Format
Click the format that you want to apply to the selected field, or click "Additional formats" to define a custom format.
When you click "Additional formats", the Number Format dialogue box opens, in which you can define a custom format. 

However there is no "Additional Formats" to click on in the list or anywhere in the dialogue. If the extended tips are turned on, pointing at the list of numbering formats displays the same information as presented in help.
The existing list has formats like a,aa,aaa... which give the impression that you might be able to define one, two, three... if you were able to access the additional formats option.
Either the help file is wrong on this or the dialogue has a bug in it.
whatever, having page numbers as words would be a nice touch

The lower case Greek numbering, αβγ actually displays as ΑΒΓ while the upper case Greek displays in lower case
Comment 1 A (Andy) 2012-11-24 09:13:57 UTC
LO 3.6.3.2. (Win7 Home, 64bit): I can also not find here an option "Additional Formats" as mentioned in the LO Help
Comment 2 A (Andy) 2014-09-28 17:11:31 UTC
Reproducible with LO 4.3.2.2 (Win 8.1)

Go to INSERT -> FIELDS -> OTHER -> DOCUMENT -> PAGE -> PAGE NUMBERS
Click on HELP and go down to the section Format, where you will find "click 'Additional formats' to define a custom format", but you will not find "Additional formats" in the list in the dialogue box.
Comment 3 QA Administrators 2015-10-14 19:56:53 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   Test to see if the bug is still present on a currently supported version of LibreOffice (5.0.1 or preferably 5.0.2.2 or later)
   https://www.libreoffice.org/download/

   If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
 If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   Update the version field
   Reply via email (please reply directly on the bug tracker)
   Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 
3. Leave a comment with your results. 
4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-10-14
Comment 4 peter Roots 2015-11-11 21:27:31 UTC
Version: 5.0.3.2
Build ID: 1:5.0.3~rc2-0ubuntu1~trusty2
Locale: en-GB (en_GB.UTF-8)
running on Linux Mint 17

Help still mentions additional formats but there is still no option for this so confirmed bug still present

(originally the upper and lower case Greek were reversed - this is resolved)
Comment 5 Cor Nouws 2016-05-23 06:24:23 UTC
Hi, 

I think the new summary explains the situation ;)
Comment 6 Cor Nouws 2016-05-23 06:26:00 UTC
OTOH, on top of the extra options one reads (specially marked): "The following fields can only be inserted if the corresponding field type is selected in the Type list." So I think its not a bug.