Download it now!
Bug 57617 - REPORTBUILDER: Report builder hang in edit mode
Summary: REPORTBUILDER: Report builder hang in edit mode
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
3.6.4.3 release
Hardware: All Windows (All)
: high normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks: Database-Reports-Builder-MAB
  Show dependency treegraph
 
Reported: 2012-11-27 16:58 UTC by olivier_musson
Modified: 2015-02-01 14:07 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description olivier_musson 2012-11-27 16:58:24 UTC
Problem description: 
Edit report in Base. Connect to native mysql source with userid and password. Add a label field in detail section. Copy a 2 paragraph text from writer and paste it in Label properties field. Then try to resize the label field added. Then base first doesn't respond and then hang.

Steps to reproduce:
1. ....Edit report for modification
2. ....Add a label field in detail section
3. ....Copy a 2 paragraph text from writer
4. ....Paster it in Label propertie field
5. ....Resize label field added

Current behavior:
Base block and then hang
Expected behavior:
Resize label field
              
Operating System: Windows XP
Comment 1 Robert Großkopf 2012-11-30 19:10:52 UTC
I couldn't confirm this behavior with a database directly in Base (HSQLDB). The MySQL native connector doesn't work with LO 3.6.3.2 and Linux, so I couldn't test it with MySQL like you did.
Where have you got the native connector from?
I don't think it has anything to do with the connection to MySQL, or does this happen only in a database with this special connection-type?
Comment 2 Ken 2012-12-15 12:47:15 UTC
I can confirm that this happens. The crash occurs when changing the size of the box/object while using the drag to re-size option. If I change the size using the properties list (i.e. enter 2.00) the box will change without fail. I do not have to paste anything into the report. Simply changing the size of the object causes a complete crash.
Comment 3 Robert Großkopf 2013-01-17 20:14:16 UTC
(In reply to comment #2)
> I can confirm that this happens.

You have confirmed this. Seems to be a windows-problem. So the Status has to be changed. I change the status to New.
Comment 4 Julien Nabet 2014-07-31 20:56:47 UTC
Any update with last stable LO version 4.2.5 and by taking into account that LO on Windows only works well with Java 32 bits (not 64 bits)
Comment 5 Alex Thurgood 2015-01-03 17:38:37 UTC
Adding self to CC if not already on
Comment 6 Alex Thurgood 2015-02-01 14:07:53 UTC
Can't reproduce on

Version: 4.5.0.0.alpha0+
Build ID: c106f83da16726506962e19bcbc3d4c25415b81a
Locale: fr_

No information from initial reporter.
Old version of LO no longer supported.
Closing as WFM