Download it now!
Bug 57645 - Color for data series not shown when FILEOPEN .xlsx (MSO2007)
Summary: Color for data series not shown when FILEOPEN .xlsx (MSO2007)
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
3.5.7.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: Confirmed:4.2.0.4:OSX
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-28 06:53 UTC by Rainer Bielefeld Retired
Modified: 2015-12-04 16:41 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample Document (13.24 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2012-11-28 06:54 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2012-11-28 06:53:50 UTC
This is a spin off from "Bug 57642 - Gradient lost when FILEOPEN .xls (MSO97)"

Steps how to reproduce [Reproducible] with parallel installation of  "LOdev  4.0.0.0.alpha1   -  ENGLISH UI / German Locale  [Build ID: dec8fe)]"  {tinderbox: @6, pull time 2012-11-13 06:07:28} on German WIN7 Home Premium (64bit) with separate /4 User Profile for Master Branch:

1. open attahced sample document "Excel2010Formatted.xlsx"
   Expected: data sieries in vertical chart bars with colors
             (for detaisl please see screenshot in test kit of Bug 57642
   Actual: black and white

Already reproducible with 3.6.4.1, 3.5.7.2, 3.5.1

With 3.4.5 color was more or less ok, but there gradient is missing.
Comment 1 Rainer Bielefeld Retired 2012-11-28 06:54:21 UTC
Created attachment 70721 [details]
Sample Document
Comment 2 A (Andy) 2012-11-29 22:02:57 UTC
reproducible with LO 3.6.3.2 (Win7 Home, 64 Bit)
Comment 3 Rainer Bielefeld Retired 2012-11-30 05:10:43 UTC
@Spreadsheet Team
Please set Status to ASSIGNED and add yourself to "Assigned To" if you accept this Bug or forward the Bug if it's not your turf (and remove others in team from CC).
Comment 4 Markus Mohrhard 2013-05-06 00:03:57 UTC
The problem is that chart2 only supports a limited number of gradients. And there is no color selection for these gradients.

@Thorsten: Do we support arbitrary colors in gradients already?
Comment 5 Thorsten Behrens (CIB) 2013-05-06 06:05:55 UTC
(In reply to comment #4)
> @Thorsten: Do we support arbitrary colors in gradients already?
>
Technically yes - or is this a ODF limitation?
Comment 6 Markus Mohrhard 2013-05-06 10:17:27 UTC
> Technically yes - or is this a ODF limitation?

I haven't checked ODF but would not worry that much about it for charts. If it is technically implemented it means we surely only have some uno problems and ui changes in chart2 to implement it.
Comment 7 retired 2014-02-15 22:54:20 UTC
Confirmed:4.2.0.4:OSX and latest nightly as of today as well.

Graphs show with color in Excel 2010 but not in LO.

So Platform -> All.
Comment 8 Kevin Suo 2014-07-16 04:48:15 UTC
Hi Rainer,

I do not reproduce this issue with version 4.2.6.1, windows XP SP3. Maybe it was fixed somewhere?

Could you please test with the latest verion to see if you still reproduce. If not, set it as WORKSFORME.

Thanks!
Comment 9 Buovjaga 2014-09-24 10:03:10 UTC
Color OK, but gradient not in effect.

Version: 4.4.0.0.alpha0+
Build ID: 0a32edcdc2bda75a7536ce7f88c91cbc56e7afb1
TinderBox: Win-x86@39, Branch:master, Time: 2014-09-24_00:45:04
Comment 10 QA Administrators 2015-10-14 19:57:05 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   Test to see if the bug is still present on a currently supported version of LibreOffice (5.0.1 or preferably 5.0.2.2 or later)
   https://www.libreoffice.org/download/

   If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
 If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   Update the version field
   Reply via email (please reply directly on the bug tracker)
   Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 
3. Leave a comment with your results. 
4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-10-14
Comment 11 Buovjaga 2015-12-04 16:41:10 UTC
Well as bug 57642 is about the gradient not matching this can be closed as WFM.

Win 7 Pro 64-bit Version: 5.2.0.0.alpha0+
Build ID: 81fa5340191baf8687f9c82f1f414f5afc86b529
Threads 4; Ver: Windows 6.1; Render: default; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-12-03_21:19:19
Locale: fi-FI (fi_FI)