Bug Hunting Session
Bug 57703 - [FILESAVE] .ppsx file created with LibreOffice doesn't Autoplay
Summary: [FILESAVE] .ppsx file created with LibreOffice doesn't Autoplay
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.6.2.2 release
Hardware: Other All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-29 21:31 UTC by Jorendc
Modified: 2014-11-06 03:08 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Error message Mac OSX (29.28 KB, image/png)
2012-11-29 22:02 UTC, Jorendc
Details
Created by LibreOffice 4.1.4.2 (31.78 KB, application/vnd.openxmlformats-officedocument.presentationml.slideshow)
2014-02-02 12:18 UTC, vulcain
Details
Created with MS Office 2010 from a PPTX. (93.86 KB, application/vnd.openxmlformats-officedocument.presentationml.slideshow)
2014-02-02 12:25 UTC, vulcain
Details
Third attachemnt after save in PPSX format with LibreOffice (237.13 KB, application/vnd.openxmlformats-officedocument.presentationml.slideshow)
2014-02-02 12:28 UTC, vulcain
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jorendc 2012-11-29 21:31:19 UTC
Tested with Ubuntu 12.10; LibreOffice 3.6.2.2 (Build-id: 360m1(Build:2)); Dutch Language Pack;

Problem: a .ppsx file created with LibreOffice doesn't auto play when double click on it. The file opens in the Impress editor.

How to reproduce:
* Open a new presentation in Impress
* Just type a word in the header for example
* Save the file as a .ppsx file (file -> save as...)
* Close impress
* Go to the directory where you saved the file
* Double click on the file
* Impress opens and goes to the editor.

Expected behavior: 
* When double clicking on the file, the file should auto play.

.ppsx extension = Office Open XML Presentation AUTOPLAY
Comment 1 A (Andy) 2012-11-29 21:53:54 UTC
reproducible with LO 3.6.3.2 (Win7 Home, 64 Bit)
Comment 2 Jorendc 2012-11-29 21:55:45 UTC
Thanks 'A' to try to reproduce.

Because this bug appears on both Ubuntu and Windows 7, I assume this bug isn't Linux Only, but appears on every platform.
Comment 3 Jorendc 2012-11-29 22:02:26 UTC
Reproducable under Mac OSX 10.8.2; LibreOffice 3.6.4 RC1;

I'll upload error message in a minute.
Comment 4 Jorendc 2012-11-29 22:02:46 UTC
Created attachment 70803 [details]
Error message Mac OSX
Comment 5 Jorendc 2012-12-21 15:38:00 UTC
Still reproducible LO 4.0.0.0.beta1
Comment 6 Florian Reisinger 2013-02-27 14:01:09 UTC
WFM with Version 4.1.0.0.alpha0+ (Build ID: 74f74aa5470fe631c7827897742c0ccbddcf6ad)
TinderBox: Win-x86@6, Branch:master, Time: 2013-02-23_23:21:01 @ Windows 7 x64
Comment 7 Jorendc 2013-02-27 14:06:19 UTC
Indeed, can't reproduce anymore using -> VERIFIED WFM
Comment 8 vulcain 2014-02-02 12:14:08 UTC
I reproduce with 
LibreOffice 4.2.0.4 Build ID: 05dceb5d363845f2cf968344d7adab8dcfb2ba71 on Ubuntu 12.04.4 x86_64  and with
LibreOffice 4.1.4.2 Build ID: 0a0440ccc0227ad9829de5f46be37cfb6edcf72 on window 7 x86_64 

Be careful, the bug is for PPSX created by LibreOffice. It's work fine if MS Office created it (see attachement).
Comment 9 vulcain 2014-02-02 12:18:51 UTC
Created attachment 93216 [details]
Created by LibreOffice 4.1.4.2

This file don't launch autoplay in MS Office 2010 ( 14.0.7106.5003 (64 bits) ). MS Office 2010 give a similar error like the first attachement: https://bugs.freedesktop.org/attachment.cgi?id=70803&action=edit

This file don't launch autoplay in LibreOffice 4.1.4.2 Build ID: 0a0440ccc0227ad9829de5f46be37cfb6edcf72
Comment 10 vulcain 2014-02-02 12:25:15 UTC
Created attachment 93218 [details]
Created with MS Office 2010 from a PPTX.

This file launch autoplay in MS Office 2010 [ 14.0.7106.5003 (64 bits)] and in LibreOffice 4.1.4.2 Build ID: 0a0440ccc0227ad9829de5f46be37cfb6edcf72

Expected result from a file save in PPSX format with LibreOffice
Comment 11 vulcain 2014-02-02 12:28:21 UTC
Created attachment 93219 [details]
Third attachemnt after save in PPSX format with LibreOffice

Autoplay is lost after save a functional PPSX with LibreOffice LibreOffice 4.1.4.2 Build ID: 0a0440ccc0227ad9829de5f46be37cfb6edcf7
Comment 12 Joel Madero 2014-11-06 03:08:09 UTC
Original reporter is saying they can't reproduce their own issue. For the follow up comment please create a new bug report with clean reproducible steps, your test file, and your operating system/version of LibreOffice.

Closing this as WFM again as the original reporter has said what he was experiencing is resolved.