Bug 57794 - German dictionary should accept Umlaut replacements as ae for ä
Summary: German dictionary should accept Umlaut replacements as ae for ä
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Linguistic (show other bugs)
Version:
(earliest affected)
3.5.7.2 release
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-02 02:11 UTC by bugquestcontri
Modified: 2013-12-09 21:00 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bugquestcontri 2012-12-02 02:11:14 UTC
Problem description: 
I am using since 30+ years keyboards without the German Umlaute in the original German writing with 2 horizontal dots above and a, o, u, and replace it with ae, oe, and ue, which is also correct German. However, all German spellchecker I ever used display an error when ae, ue, or oe is used. 

I add all these words manually into the user defined dictionaries. 

As I assume that there are quite many people around the globe with the same issue I wrote this enhancement request.

Enhancement request
Provide a German dictionary, which includes the ae, ue, and oe way of writing. I am willing to contribute my user defined dictionary for extracting all words. I have user defined dictionaries in LibO, MSO and Thunderbird.

By the way, the same can be made for the German sz-character and its replacement with ss. My collection of such words are also in my user defined dictionaries, which I offered to contribute.


Operating System: Windows XP
Last worked in: 3.5.7.2 release
Comment 1 Michael Stahl (allotropia) 2012-12-04 19:33:07 UTC
clearly not a regression
Comment 2 Rainer Bielefeld Retired 2012-12-05 06:42:51 UTC
I doubt that it is useful to add thousands of alternative words, more useful would be an option "accept replacements".
Comment 3 bugquestcontri 2012-12-05 07:17:18 UTC
If "accept replacements" could be enabled, that would even be better. It would be only replacements for ae, ue, oe, and sz. This would even be a feature MSO doesn't have. I am looking forward to see this in LibO.
Comment 4 Julien Nabet 2013-07-22 12:19:26 UTC
Andras: you might be interested in this one. I don't know if "accept replacements" as Rainer suggested in comment 2 should be used but if this is the case, some code pointers may be useful.
Comment 5 Andras Timar 2013-12-09 21:00:49 UTC
This should be reported to upstream, LibreOffice uses German Hunspell dictionary as is. See http://extensions.libreoffice.org/extension-center/german-de-de-frami-dictionaries

Adding the following lines to .aff file give the desired result, but there may be drawbacks that I did not think of, or the request is invalid -- I cannot judge, because I'm not a German linguist.

ICONV 4
ICONV ae ä
ICONV oe ö
ICONV ue ü
ICONV sz ß