Download it now!
Bug 57814 - most of the menus are half visible or not visible
Summary: most of the menus are half visible or not visible
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
3.6.4.3 release
Hardware: x86 (IA32) Linux (All)
: medium major
Assignee: Björn Michaelsen
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-02 19:05 UTC by Tazir
Modified: 2013-05-08 18:14 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
Showcase (72.80 KB, image/png)
2012-12-02 19:08 UTC, Tazir
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tazir 2012-12-02 19:05:39 UTC
Default libreoffice with ubuntu 11.10 and 12.04 - most of the menus under libreoffice are half visible or not visible ( a "_" is visible in place of most menus and options under it).
LibreOffice 3.5 and 3.6.0.1
Ubuntu 11.10, 12.04

http://ask.libreoffice.org/question/1429/libreoffice-3512-menu-problem/
Comment 1 Tazir 2012-12-02 19:08:18 UTC
Created attachment 70940 [details]
Showcase
Comment 2 Rob Snelders 2012-12-02 19:19:32 UTC
Set this bug to Bjoern. He is the maintainer for LibreOffice in Ubuntu. Maybe he knows the problem.
Comment 3 Adolfo Jayme 2013-01-22 10:05:13 UTC
While I have never experienced this problem with LibreOffice under Ubuntu, I have an idea. You seem to be using Arial, a MS proprietary font, as your UI font. I have observed that these fonts disappear from the UI if I don't give proper permissions to the font files. You may want to check file permissions with your file manager.
Comment 4 Pierre Ossman 2013-05-07 11:16:00 UTC
Also seeing this in ThinLinc (a VNC server) in multiple versions:

 - SLED 11: 3.6.5.2.15
 - Fedora 18: 3.6.6.2
 - Fedora 19: 4.0.3.3

So it seems to be a general bug rather than something distribution specific.

Looking at the behaviour, it looks a bit like there is a race going on between the code filling out the menu, and the code blitting it to the X server. Opening the menu will randomly get some of the entries. Compositing (e.g. gnome 3) also solves the problem.
Comment 5 Pierre Ossman 2013-05-07 11:20:52 UTC
Also happens with Fedora's bundled TigerVNC server.
Comment 6 Pierre Ossman 2013-05-07 13:01:28 UTC
Turned out to be a VNC issue in our/TigerVNC's case. The "Glyphs" XRENDER operation is no longer built on top of the "Composite" operation, so change tracking was off. Fixed upstream. Sorry for the noise.