Bug Hunting Session
Bug 57860 - FILESAVE: file extension not added when saving a file with '.' in filename
Summary: FILESAVE: file extension not added when saving a file with '.' in filename
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.6.3.2 release
Hardware: All Windows (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-04 02:43 UTC by James Evensen
Modified: 2015-05-30 15:15 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
save with .com extension (2.12 MB, application/x-shockwave-flash)
2013-10-05 10:58 UTC, Andrej
Details

Note You need to log in before you can comment on or make changes to this bug.
Description James Evensen 2012-12-04 02:43:23 UTC
When saving a file with a '.' in the file name, LibreOffice does not add the file extension to the document.  For instance, if a document is saved with the name "untitled.1," that is what it will be saved as.

To reproduce, create a new LibreOffice document and save it with '.' in the file name.  The resulting document will not have a file extension.

This occurs with the "Automatic file name extension" checkbox checked.
Comment 1 Samuel Mehrbrodt (CIB) 2012-12-23 17:03:31 UTC
I reproduced this when using "filename.123" as filename.

But it does not happen always, when you have a period in the filename. For example, 'filename.1' works for me, the extension is added.
Comment 2 Andrej 2013-10-05 10:58:49 UTC
Created attachment 87151 [details]
save with .com extension
Comment 3 Andrej 2013-10-05 11:01:15 UTC
Comment on attachment 87151 [details]
save with .com extension

I have a file "test.com.odt"
Open and save as "2test.com"
then the new file can not be opend
Comment 4 Andrej 2013-10-05 11:03:54 UTC
Comment on attachment 87151 [details]
save with .com extension

I have a version: 4.1.1.2
Comment 5 booking 2013-12-06 15:47:47 UTC
Comment on attachment 87151 [details]
save with .com extension

I have just experienced this issue by saving as .docx file with the name "filename.com", how can I restore the .com file to a .docx file?
thank youuu

Vanessa
Comment 6 Samuel Mehrbrodt (CIB) 2013-12-06 20:03:03 UTC
@Vanessa: Your file has a .swf ending?
Comment 7 QA Administrators 2015-04-19 03:22:28 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   *Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1 or later)
   https://www.libreoffice.org/download/

   *If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
   *If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   *Update the version field
   *Reply via email (please reply directly on the bug tracker)
   *Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 
3. Leave a comment with your results. 
4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-04-18
Comment 8 James Evensen 2015-04-26 00:10:16 UTC
Tested the latest version and extensions are now correctly applied to the file name.
Version: 4.4.2.2
OS: Windows 7
Comment 9 Andrej 2015-05-30 15:15:57 UTC
Version: 4.4.3.2  works fine for me too.