Bug 57884 - Checkboxes in LibreOffice Writer documents disappear
Summary: Checkboxes in LibreOffice Writer documents disappear
Status: RESOLVED DUPLICATE of bug 43765
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.4.2 release
Hardware: All Windows (All)
: high critical
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-04 16:35 UTC by Eric Van Den Berghe
Modified: 2013-07-07 05:39 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Checkboxes disappear in LibreOffice Writer (20.90 KB, application/vnd.oasis.opendocument.text)
2012-12-04 16:35 UTC, Eric Van Den Berghe
Details
Checkboxes disappear in LibreOffice Writer (146.61 KB, application/vnd.oasis.opendocument.text)
2012-12-04 16:37 UTC, Eric Van Den Berghe
Details
Checkbox disappears when selected, if a 'Page Count'-field is inserted and design mode is off. (13.28 KB, application/vnd.oasis.opendocument.text)
2012-12-10 13:59 UTC, Eric Van Den Berghe
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Eric Van Den Berghe 2012-12-04 16:35:35 UTC
Created attachment 71002 [details]
Checkboxes disappear in LibreOffice Writer

Bug in LibreOffice Writer – Checkboxes disappear in LibreOffice Writer

After migration from OpenOffice.org 3.2 to LibreOffice 3.6.2.2 we have a problem with disappearing checkboxes in LibreOffice Writer. We do not have this problem in OpenOffice.org Writer.

In tests with LibreOffice version 3.6.3, 3.6.4(RC1), 3.6.5 (dev) and in beta version 4.0.0.0 this problem still exists. See also the included document “Engels.odt”.
Comment 1 Eric Van Den Berghe 2012-12-04 16:37:45 UTC
Created attachment 71003 [details]
Checkboxes disappear in LibreOffice Writer
Comment 2 m.a.riosv 2012-12-10 00:53:03 UTC
Reproducible for attachment.
If form design mode is on, do not disappear.

Win7x64 Ultimate
LibreOffice Version 3.6.4.3 (Build ID: 2ef5aff)
LODev Version 4.0.0.0.beta1+ (Build ID: 465d3512cca457c79e6ef85ad1cbf6bcc88e888)

Not reproducible with:
LibreOffice 3.5.7.2 Build ID: 3215f89-f603614-ab984f2-7348103-1225a5b

But creating a new file and inserting a checkbox this does not happen.
Comment 3 Eric Van Den Berghe 2012-12-10 13:59:49 UTC
Created attachment 71266 [details]
Checkbox disappears when selected, if a 'Page Count'-field is inserted and design mode is off.

Bug in LibreOffice Writer version 3.6 and above (also Version 4.0.0.0.alpha0+ (Build ID: 677a3f):
A checkbox disappears when selected, if a 'Page Count'-field is inserted and design mode is off.

Number of pages: [1] (='Page Count'-field)

Checkbox disappears when selected if a 'Page Count'-field is inserted and the design mode is off:
[ ] Check Box


- When design mode is on the 'Check Box' (above) does not disappear.
- When design mode is off the 'Check Box' disappears when you select the 'Check Box'.
- When the 'Check Box' is disappeared and you click on the 'Page Count'-field the 'Check Box'-field is briefly displayed (and disappears again).
- When the 'Page Count'-field is deleted the checkbox does not disappears, even if the design mode is on or off.

See test with document "CheckboxesDisappear.odt" in attachtment.
Comment 4 m.a.riosv 2012-12-10 19:22:00 UTC
Confirmed.
Win7x64 Ultimate
LODev Version 4.0.0.0.beta1+ (Build ID: 465d3512cca457c79e6ef85ad1cbf6bcc88e888)

Checkbox disappears, if a 'Page Count'-field is inserted and design mode is off.
Comment 5 Eric Van Den Berghe 2013-03-08 12:07:39 UTC
This bug still exist in LibreOffice Writer version 4.0.1.2 .1.2 (Bouw-id: 84102822e3d61eb989ddd325abf1ac077904985)

Is it possible to fix this bug in the next release of LibreOffice?
Comment 6 Pascal Becker 2013-03-20 12:14:00 UTC
I also have this problem in Version 4.0.1.2.
The checkboxes change from visible to invisible and back randomly when the mouse is moved or when scrolling the document.

Seems the checkboxes only disapear when design mode is off. With design mode on, everything works fine.
Comment 7 Michael Stahl 2013-06-24 13:49:25 UTC
Comment on attachment 71266 [details]
Checkbox disappears when selected, if a 'Page Count'-field is inserted and design mode is off.

fix wrong mime type...
Comment 8 Michael Stahl 2013-06-24 18:26:03 UTC

*** This bug has been marked as a duplicate of bug 43765 ***
Comment 9 Klaus R. 2013-07-07 05:36:44 UTC
UBUNTU 12.04 LibreOffice 4.0.4.2

The checkboxes change from visible to invisible and back randomly
in normal view, not in design mode or webview!

Would be great to get this solved soon.

A little workaround to get some fillable forms in LibreOffice (not in pdf-form):

Use textfield with maxchar = 1 and password sign = X
Comment 10 Klaus R. 2013-07-07 05:39:02 UTC
UBUNTU 12.04 LibreOffice 4.0.4.2

The checkboxes change from visible to invisible and back randomly
in normal view, not in design mode or webview!

Would be great to get this solved soon.

A little workaround to get some fillable forms in LibreOffice (not in pdf-form):

Use textfield with maxchar = 1 and password sign = X

*** This bug has been marked as a duplicate of bug 43765 ***