Download it now!
Bug 57916 - [21] Document master ignores chapter numbers of sub documents
Summary: [21] Document master ignores chapter numbers of sub documents
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.3.2 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-05 16:44 UTC by Christian Kaiser
Modified: 2014-07-21 04:42 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Howto of creation of master document and numbering (391.84 KB, application/pdf)
2013-06-24 20:55 UTC, Christian Kaiser
Details
Master document, where the bug appears (9.21 KB, application/vnd.oasis.opendocument.text-master)
2013-06-24 20:56 UTC, Christian Kaiser
Details
Sub document, which is inserted into master document (9.14 KB, application/vnd.oasis.opendocument.text)
2013-06-24 20:57 UTC, Christian Kaiser
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christian Kaiser 2012-12-05 16:44:29 UTC
When I create an new master document (ODM) out of a normal template (OTT) with LibreOffice 3.6.3.2 (same issue with 3.6.2.2), I have the following problem with this master.

I create sub documents with chapter numbers and merge them into the master document. In the master document the numbering gets lost.

This behaviour occurs only with newly generated masters. Masters, which are created in older versions of LibreOffice or the current version of OpenOffice, keep the numbering when I use LibreOffice 3.6.3.2 to merge sub documents into them.
Comment 1 Owen Genat (retired) 2013-06-03 06:13:35 UTC
You are probably going to have to provide a working example that can be used to illustrate the problem. To be clear, are the ODTs also based on the same OTT? Also, how are the chapter numbers set: a) Outline Numbering; b) linking the Heading N style with a Numbering N style; c) defining numbering for a heading (via toolbar)?
Comment 2 Christian Kaiser 2013-06-24 20:55:20 UTC
Created attachment 81369 [details]
Howto of creation of master document and numbering

In this document I describe my steps of creating the master document and the numbering.
Comment 3 Christian Kaiser 2013-06-24 20:56:36 UTC
Created attachment 81370 [details]
Master document, where the bug appears

This is the master document, where the numbering of the sub document does not appear.
Comment 4 Christian Kaiser 2013-06-24 20:57:46 UTC
Created attachment 81371 [details]
Sub document, which is inserted into master document

This is the sub document, which heading numbering does not appear in the master document.
Comment 5 Christian Kaiser 2013-06-24 20:59:49 UTC
Please have a look at my attachments. I made a "howto" to reproduce the bug. The documents master.odm and sub.odt are the docmuents, I worked with.
Comment 6 Owen Genat (retired) 2013-11-13 09:19:44 UTC
Sorry I have taken so long to respond. For some reason I did not see the updates provided back in June 2013. Thank you for providing them. The problem appears to be a workflow / method issue stemming from the use of direct formatting and lack of a template. I do not create master documents in the manner described in the attachment to comment #2. The following method works for me and has done since at least v3.5.

1. Start Writer.
2. Tools > Outline Numbering > select Level 1-10; Number 1,2,3; Separator After full stop (.) > click OK. If outline numbering is required against headings, use this facility rather than any sort of list-related styling.
3. Save this document as a template (the method for doing this has changed across versions, but in the v4.x series is currently File > Save as Template...). All documents (master + sub) should be based on this template.
4. Open a new document based on the newly created template.
5. Press ENTER to create a new carriage return (i.e., some content). I am not sure why direct formatting is used to select the Heading style in step #1 of the provided instructions. If this is important the Heading style can be applied if necessary via the Styles and Formatting panel at this point.
6. File > Send > Create Master Document > enter file name and click Save.
7. Open a second new document based on the newly created template.
8. Enter "Heading 1" and assign this text the Heading 1 style; press ENTER; enter "Heading 2" and assign the text the Heading 2 style. There should be two lines of text, the first reading "1. Heading 1" and the second reading "1.1. Heading 2"; save this document as the sub-document.
9. Swap back the master document; in the Navigator select Insert > File > select the sub-document > click Open.
10. Headings are inserted with numbering.

That is essentially the method outlined in chapter 13 of the Writer Guide v4.0. Refer in particular "Styles in master documents and subdocuments" (p.366) and "Combining several documents into a master document" (p.368).
Comment 7 Joel Madero 2014-07-21 04:42:45 UTC
Closing as comment 6 describes what the user was seeing and how to resolve it by following the LibreOffice writer guide.

Closing as NOTABUG

@Christian - if following the guidelines provided by Owen does not work for you set this back to unconfirmed. Thanks