Bug 57966 - 100% CPU usage with particular .odt file
Summary: 100% CPU usage with particular .odt file
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.4.3 release
Hardware: Other All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2012-12-07 04:00 UTC by Emir Sarı
Modified: 2013-11-16 19:23 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
sample file (128.48 KB, application/vnd.oasis.opendocument.text)
2012-12-07 04:00 UTC, Emir Sarı
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Emir Sarı 2012-12-07 04:00:27 UTC
Created attachment 71111 [details]
sample file

Hello, OS X 10.7.5, LO 3.6.4.3

CPU usage tops 100%-120% with specific .odt file attached. 

This behaviour was not present with 3.5 as far as I remember. 

Not reproducible with 4.0.0.0 alpha1 28-11 build.
Comment 1 Michael Stahl (CIB) 2012-12-13 14:24:59 UTC
can't reproduce here on Linux with 3.6.4.3

the layout hogs the CPU for a few seconds but that is quite
normal, layout for 250 page document is not done in an instant.

but after 15-20 seconds CPU time it goes idle here,
on 3.5.7, 3.6.4 and master; there appears to be no
difference between them.

this needs a bit more detail as to what exactly is going wrong
(if anything); maybe it's somehow Mac specific or whatever.
Comment 2 QA Administrators 2013-09-24 01:48:04 UTC
Dear Bug Submitter,

This bug has been in NEEDINFO status with no change for at least 6 months. Please provide the requested information as soon as possible and mark the bug as UNCONFIRMED. Due to regular bug tracker maintenance, if the bug is still in NEEDINFO status with no change in 30 days the QA team will close the bug as INVALID due to lack of needed information.

For more information about our NEEDINFO policy please read the wiki located here: 
https://wiki.documentfoundation.org/QA/FDO/NEEDINFO

If you have already provided the requested information, please mark the bug as UNCONFIRMED so that the QA team knows that the bug is ready to be confirmed.


Thank you for helping us make LibreOffice even better for everyone!


Warm Regards,
QA Team
Comment 3 Emir Sarı 2013-09-24 09:12:18 UTC
No issues with the latest OS X master.

Closing.