Bug Hunting Session
Bug 58091 - Windows 8, High Memory (RAM) Usage, Above 600MB (~700MB), When COPYING Unicode text in LibreOffice Writer, QuickStarter
Summary: Windows 8, High Memory (RAM) Usage, Above 600MB (~700MB), When COPYING Unicod...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.4.3 release
Hardware: x86 (IA32) Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-10 16:09 UTC by Azoxy
Modified: 2015-02-19 16:00 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
LibreOffice Writer v3.6.4.3, Screenshot, Task Manager of Windows 8 Pro (on 12-12-2012) (316.77 KB, image/jpeg)
2012-12-12 08:53 UTC, Azoxy
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Azoxy 2012-12-10 16:09:33 UTC
I'm using LibreOffice from its launch. Even was using OpenOffice from a long time.

I recently upgrade my laptop's operating system to "Windows 8 Pro". But i'm facing a big problem with LibreOffice. I was expecting, that it may get fixed in the next version of LibreOffice. But, i see it still exists in version 3.6.4 also. So, i decide to report this bug here. Here is the situation:

Platform :

* Windows 8 Pro 32bit, x86
* LibreOffice v3.6.4.3

Problem :

* High memory usage (RAM)
* Above 600MB (~700MB)

Frequency :

* Sometimes while using WRITER.
* Sometimes while QuickStarter running.

Contents :

* Encoding - Unicode (Gurmukhi, Punjabi, PA)
* File - MS Office .doc document

Event (When) :

* While QuickStarter stay in the tray for some time after boot the system.
* When apply copy command to copy Unicode (PA) text from the .DOC document.

I'm not a system programmer. So, don't know how to capture technical debug information for this problem. I hope, somebody may take a look on this.

-- 
Thanks
Comment 1 Azoxy 2012-12-12 08:53:30 UTC
Created attachment 71382 [details]
LibreOffice Writer v3.6.4.3, Screenshot, Task Manager of Windows 8 Pro (on 12-12-2012)

The screenshot image showing memory (RAM) usage in "Task Manager" of "Windows 8 Pro" operating system.

I did open only 16kb "MS Word .doc" document. Selected all text (Ctl+A) & pressed COPY (Ctl+C) command.

You can see in screenshot (attached), what happened. System freezes for few seconds and the more than 800MB RAM (memory) occupied by LibreOffice.
Comment 2 ydutrieux 2012-12-20 12:55:17 UTC
Not reproduced on Libo4 (Version 4.0.0.0.beta1 (Build ID: 87906242e87d3ddb2ba9827818f2d1416d80cc7)

Win8 CP - 32bits sous VirtualBox.

@Azoxy, 
have you same text you can join in attachment to try to reproduce ?

Could you take a log with PROCMON.EXE 
(http://technet.microsoft.com/en-us/sysinternals/bb896645.aspx)
Step to log : 
1- <Just before reproduce the problem of memory>, start procmon.exe
2- As soon it's started (don't wait too much , procmon log a lot of data ;-))
   reproduce your problem with libo
3- when problem is reproduced, you can stop PROCMON.EXE with the "Zoom"/"lens" icons (Third icon).
4- File - Save... 
     [X] All events
    <look at the file where the log will be saved>
     [OK]
5- <Right-clic on this file>-send to.. - compressed folder
6- send me your logfile.zip to my personnal email address (file will be probably large).
I will look at this to see if there is something causing this problem.
Comment 3 Azoxy 2012-12-27 23:35:47 UTC
Hi @ydutrieux !

As you said, I captured a log for the problem. Files sent to your personal email address with subject:

"Re: [Bug 58091] High Memory Usage ... LibreOffice Writer"


Files sent:

1. Screenshot.jpg = Screenshot of Task Manager on Windows 8 Pro
2. Document.doc = The file I opened in  LibreOffice Writer
3. Logfile.zip = Contains "LogFile." captured from "procmon.exe"


Here are the steps i followed:

1. Start "procmon.exe" & minimized
2. Open "Document.doc" file in Writer
3. "Ctr+A" than "Ctr+C" to copy
4. Option Task Manager & make a screenshot
5. Close "Writer" application
5. Stop "procmon.exe" events logging & save logfile.
6. Done


I hope this LogFile may give you some information about the reason of this problem.


Good Luck !


- - Azoxy
Comment 4 Jorendc 2013-01-28 20:19:12 UTC
Is it possible to attach this document to this bug report (and if it is confidential to send it to my email)? I would like to reproduce this behavior.

Kind regards,
Joren
Comment 5 Ino 2013-01-30 14:51:51 UTC
I have the same issue happening in Writer and Calc.
It also happens in OpenOffice, not just LibreOffice.

Platform:
* Windows 8 Pro 64 bit (Portuguese)
* Libreoffice
* OpenOffice (3.0, 3.2, 3.4.1)

Where it happens:
* Writer and Calc (possibly other apps too)

What happens:
After approx. 1-5 copy (ctrl+c) operations, writer (or calc) hangs, and memory usage jumps from ~120MB to 1.250GB in about 3 seconds.

I can confirm everything that happens on the previously posted screenshot, both the main process and the soffice.bin allocating too much memory.

Sometimes the program responds after 20 seconds, and other times the only solution is to end the task in the task manager.
Comment 6 QA Administrators 2015-02-19 15:38:54 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.0.3 or later): https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior

If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

Thank you for your help!

-- The LibreOffice QA Team
This NEW Message was generated on: 2015-02-19
Comment 7 Azoxy 2015-02-19 16:00:57 UTC
This bug is not present is current stable version.