Download it now!
Bug 58095 - DOC Import creates an invalid style name
Summary: DOC Import creates an invalid style name
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.4 release
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-10 16:49 UTC by Urmas
Modified: 2015-06-18 13:53 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Minimal document to reproduce (4.39 KB, application/msword)
2012-12-10 16:49 UTC, Urmas
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Urmas 2012-12-10 16:49:55 UTC
Created attachment 71282 [details]
Minimal document to reproduce

Several MS Word documents like the attached show empty style name after being opened with Libreoffice. The opened document cannot be saved in any format, including ODF.

Either styles should be correctly imported, or software should prevent creation of invalid style names.
Comment 1 Joel Madero 2012-12-11 17:31:48 UTC
Confirmed.

New (Confirmed)

Major (you can open a file, make a ton of edits, but when you try to save you're stuck, it spits out an error)

High (potential for loss of data + major annoyance if a user opens a file with no error and then finds out they can't save the file)

Version: Confirmed on 3.6.3.2, changing version to reflect oldest version confirmed on
Comment 2 stfhell 2012-12-13 10:32:48 UTC
(Also reproducible with LO 3.5.4.2/Ubuntu 12.04, so changing version field.)

But consider that MS Office 2010 doesn't open the file as well by default. See
http://support.microsoft.com/kb/922849/
for Office policy restrictions (support for the old DOC file formats has been restricted from Word 2003 onwards because Microsoft isn't keen on fixing or hardening the code for their old file formats).

I cannot imagine users will be very likely to come across such a file. But to fix the issue in LO, it would be necessary to find out if LO really imports a correctly defined paragraph style without its name, if it adds a style not defined in the DOC to its style list, or if the DOC file itself is corrupt and LO doesn't detect this.

What application was the file created with?
Comment 3 Urmas 2012-12-14 15:28:13 UTC
Another linuxlie? The document is opened by Microsoft office without issues.
Comment 4 stfhell 2012-12-17 17:33:34 UTC
Security policies are no issues, they are security policies. The file is an old WinWord-2.0 DOC, and this format should better be avoided for current documents, especially since it's not openly documented. I have never seen this bug with the later compound-doc formats, so it's probably limited to WinWord 2.0 files.
Comment 5 Urmas 2013-08-21 01:15:35 UTC
The problem is apparently caused by a trailing 0xff in the names part of the stylesheet.
Comment 6 Yuhong Bao 2013-09-04 23:47:45 UTC
"Word 2003 onwards"
Word 2003 SP3 and Word 2007 onwards.
Comment 7 QA Administrators 2015-04-19 03:22:20 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   *Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1 or later)
   https://www.libreoffice.org/download/

   *If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
   *If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   *Update the version field
   *Reply via email (please reply directly on the bug tracker)
   *Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 
3. Leave a comment with your results. 
4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-04-18
Comment 8 Buovjaga 2015-06-18 13:53:52 UTC
No empty style name, was able to save in .odt and .doc. WFM.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: 437210d58f32177ef1829d704f7f4d2f1bbfbfdd
TinderBox: Win-x86@39, Branch:master, Time: 2015-06-18_07:21:56
Locale: fi-FI (fi_FI)