Bug Hunting Session
Bug 58181 - FORMATTING: Cell Formatting (Right To Left) Not Saved With XLSX Format
Summary: FORMATTING: Cell Formatting (Right To Left) Not Saved With XLSX Format
Status: RESOLVED DUPLICATE of bug 58122
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.5.4 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsDevEval
Depends on:
Blocks:
 
Reported: 2012-12-12 10:29 UTC by Ibrahim Hammad
Modified: 2015-12-18 10:26 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ibrahim Hammad 2012-12-12 10:29:24 UTC
Problem description: 

When selecting the whole sheet and chose to make the direction of the cells from right to left ( Left to Right is the default) and save and close the document, then after opening it again this direction is not saved and the default direction is replaced instead.

Steps to reproduce:
1. select whole sheet
2. change the direction of the cells to right to left (left to right is the default)
3. Save & close the document
4. open the document again
5- the direction of the cells is turned back to default

worth mentioning that the sheet is saved as Ms Excel format on a windows partition not on the ubuntu's partition.

Current behavior:

A change of the cell direction of a sheet is not saved when the document is closed.

Expected behavior:

Action of changing the direction of the cell should be saved and carried on until changed by user.              
Operating System: Ubuntu
Comment 1 Joel Madero 2013-05-29 18:08:17 UTC
Thank you for reporting this issue! I have been able to confirm the issue on:
Version: 4.2.0.0.alpha0+Build ID: b0a1666f756aa5f5315366eca9d7d02ddd55d2b
Date:   Tue May 28 08:51:01 2013 +0300 
Platform: Bodhi Linux 2.2 x64

+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + +
As I've been able to confirm this problem I am marking as:

New (confirmed)
Normal - can prevent high quality work, potentially a major bug as it losses data (some could argue) but for now, normal bug
High - because it's borderline major, I am marking as high priority

ProposedEasyHack


+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + +
LibreOffice is powered by a team of volunteers, every bug is confirmed (triaged) by human beings who mostly give their time for free. We invite you to join our triaging by checking out this link:
https://wiki.documentfoundation.org/QA/BugTriage and join us on freenode at #libreoffice-qa

There are also other ways to get involved including with marketing, UX, documentation, and of course developing -  http://www.libreoffice.org/get-help/mailing-lists/. 

Lastly, good bug reports help tremendously in making the process go smoother, please always provide reproducible steps (even if it seems easy) and attach any and all relevant material
Comment 2 Robinson Tryon (qubit) 2013-10-19 01:24:27 UTC
Removing comma from whiteboard (please use a space to delimit values in this field)
https://wiki.documentfoundation.org/QA/Bugzilla/Fields/Whiteboard#Getting_Started
Comment 3 Joel Madero 2014-02-27 23:03:40 UTC
In order to limit the confusion between ProposedEasyHack and EasyHack and to make queries much easier we are changing ProposedEasyHack to NeedsDevEval.

Thank you and apologies for the noise
Comment 4 Priyanka Gaikwad 2015-05-26 08:41:16 UTC

*** This bug has been marked as a duplicate of bug 58122 ***
Comment 5 Robinson Tryon (qubit) 2015-12-18 10:26:12 UTC
Migrating Whiteboard tags to Keywords: (needsDevEval)
[NinjaEdit]