Download it now!
Bug 58218 - Put Paragraph Border Styles In Consistent Order
Summary: Put Paragraph Border Styles In Consistent Order
Status: RESOLVED DUPLICATE of bug 126649
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.4.3 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: Borders-Tab
  Show dependency treegraph
 
Reported: 2012-12-12 23:20 UTC by freyraphael
Modified: 2019-08-08 13:16 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Paragraph Border Styles (Current State & Proposals) (48.77 KB, application/pdf)
2012-12-12 23:20 UTC, freyraphael
Details
Paragraph Border Styles - ODT Version (10.56 KB, application/vnd.oasis.opendocument.text)
2012-12-12 23:22 UTC, freyraphael
Details

Note You need to log in before you can comment on or make changes to this bug.
Description freyraphael 2012-12-12 23:20:32 UTC
Created attachment 71416 [details]
Paragraph Border Styles (Current State & Proposals)

I've attached a PDF document to this bug report. The first page shows the current order of the paragraph border styles. There are some borders that come in pairs of two - one of them is mirrored. I've given these border pairs the same number, but added an index (a or b).

Now, as you can see, the order of the corresponding border styles is not consistent which leads to confusion:

5a - 6a - 7a - 5b - 6b - 7b - 8a - 8b - 9a - 9b

The correct order should be:

5a - 5b - 6a - 6b - 7a - 7b - 8a - 8b - 9a - 9b

The second page in the PDF shows the correct order. (The moved border styles are typed in blue colour.)

I would even suggest to delete border styles 5a & 5b as they are nearly identical to style 1, and to replace 7a & 7b with a symmetrical style (same thickness of upper and lower line) as the two are virtually identical.(*) See PDF page 3 for this suggestion.


(*) Please note that I've used the largest paragraph border width (9 pt) in the PDF. With smaller line widths, the differences are even smaller.
Comment 1 freyraphael 2012-12-12 23:22:34 UTC
Created attachment 71417 [details]
Paragraph Border Styles - ODT Version
Comment 2 Jorendc 2012-12-14 18:26:30 UTC
Not a bug -> changed to 'enhancement'. 

Thanks for reporting and put them in a more consistent order. The developers are now busy to fix libreoffice 4.0 bugs before the release in February. I hope they will pick this enhancement up when there is more time.
Comment 3 Björn Michaelsen 2015-03-05 10:16:20 UTC
Doesnt seem hardware specific.
Comment 4 Heiko Tietze 2019-08-08 13:16:43 UTC
Sorry for making this older ticket the duplicate but work is done on the other right now.

*** This bug has been marked as a duplicate of bug 126649 ***