Bug Hunting Session
Bug 58266 - calc looses/breaks diagrams/charts + fails @ cut and paste of diagrams EDITING VIEWING
Summary: calc looses/breaks diagrams/charts + fails @ cut and paste of diagrams EDITIN...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.3.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-13 20:53 UTC by Andreas Schleth
Modified: 2015-02-22 08:17 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
zip file with *.ods and 4 screenshots describing the problem (395.02 KB, application/zip)
2012-12-13 20:53 UTC, Andreas Schleth
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Schleth 2012-12-13 20:53:47 UTC
Created attachment 71467 [details]
zip file with *.ods and 4 screenshots describing the problem

create a simple bar chart from eg. 2 short columns of random data.

fail 1:  copy and paste the chart somewhere else to the same sheet: 
 a) the new chart area is blank (should be the same diagram as before), 
 b) there is no way to edit the second chart into something chart-like

fail2:  start from scratch as before (one diagram) and save as *.ods. Then reload the document and find: the chart is blank and broken as above.
Comment 1 James Bottomley 2012-12-19 12:06:09 UTC
I just saw this behaviour as well with

libreoffice-calc-3.6.3.2.3-3.4.x86_64

from openSUSE:Tumbleweed

A spreadsheet with a chart was saved, and on reopening, all the chart setup had disappeared
Comment 2 Dominik Kopp 2012-12-31 08:50:09 UTC
see also bug report
https://bugzilla.novell.com/show_bug.cgi?id=794698
Comment 3 Hans Peter Schwob 2013-01-05 09:57:50 UTC
I use Libre Office 3.5.7.2, the newest version for Win7/German. The error happens since last update on 2012-11-18.

In my case, some of the diagrams have disappeared, when I save and reopen the file. The file contains 16 sheets, nearly all with one diagram. Some diagrams are still there, some shifted to the upper left corner, some disappear completely. It might be, all diagrams created before the last update remain, but the behaviour is not clear. Older files show the diagrams, until the diagram is moved or changed.
Comment 4 Hans Peter Schwob 2013-01-05 10:45:07 UTC
Changed now to version 3.6.4 (LibO_3.6.4_Win_x86_install_multi.msi). (Search for updates said I had installed actual version. Found newer version on bugzilla!)

But problem still exists. One way, which is reproducible:
- copy one sheet with diagram to new document. This document shows diagram.
- Save this new document.
- Open new document: The diagram disappeared.
Comment 5 Hans Peter Schwob 2013-01-05 15:00:05 UTC
Additional Info to comment 3 & 4

I installed Apache-Open-Office 4.1 (actual version) and the problem is gone. Also other problems with the diagrams are gone, also some nice features. I am sad to leave LibreOffice, but I just cannot live with these problems.
Comment 6 Heinz Repp 2013-02-18 22:05:25 UTC
I think this is related: with 3.5.7 on Ubuntu 12.04 LTS (I am forced to use this version as 3.6.x breaks scrolling in writer) spreadsheets created with previous version mostly show the diagrams moved top left. I did not modify this files, as I have not enough trust in a program that gets things so wrong, so I cannot report lost diagrams.
Comment 7 QA Administrators 2015-02-19 15:31:22 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.0.3 or later): https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior

If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

Thank you for your help!

-- The LibreOffice QA Team
This NEW Message was generated on: 2015-02-19
Comment 8 Jean-Baptiste Faure 2015-02-22 08:17:12 UTC
The chart in the attachment is clearly corrupted (blank area, nothing can be changed). But if you remove the chart and remake it, it works as expected:
1/ copy&paste elsewhere: no problem
2/ edit the second chart: no problem
3/ save the file as .ods and reload: no problem.

Closing this bug report as WorksForMe.
Because many work has been done on Chart module, please do not reopen if you have problem with chart but open a new one. Thank you for understanding.

Best regards. JBF