Bug 58367 - Accuracy of calculation of a big numbers
Summary: Accuracy of calculation of a big numbers
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.4.3 release
Hardware: x86-64 (AMD64) Linux (All)
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-16 15:41 UTC by Taufik Hasan
Modified: 2013-11-16 19:50 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
File Showing error in calculation (19.79 KB, application/vnd.oasis.opendocument.spreadsheet)
2012-12-16 15:41 UTC, Taufik Hasan
Details
Reformated file with decimal positions. (15.89 KB, application/vnd.oasis.opendocument.spreadsheet)
2012-12-16 23:00 UTC, m.a.riosv
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Taufik Hasan 2012-12-16 15:41:49 UTC
Created attachment 71588 [details]
File Showing error in calculation

Result of a calculation is in error, direct calculation gives good result (compare with a calculator)
File attached.
Comment 1 m.a.riosv 2012-12-16 23:00:35 UTC
Created attachment 71606 [details]
Reformated file with decimal positions.

There are numbers with decimals positions, so the calculations are being done with different numbers, in direct calculations you are using rounded numbers.

J3: =5105846,8282900
M11: =360000
J16: = J3*M$11   result 1838104858184,400000
J17: =5105847*360000

5105847 in J17 not equal to J3

Attached file changing the viewing cells format.
Comment 2 m.a.riosv 2012-12-16 23:00:53 UTC
Not a bug.
Please if you are not agree, reopen the bug.