Bug 58541 - BASIC: BASIC runtime error '423' OnSheetActivate
Summary: BASIC: BASIC runtime error '423' OnSheetActivate
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: BASIC (show other bugs)
(earliest affected) release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
Whiteboard: BSA
Depends on:
Blocks: Error-Messages Macro-VBA-Error423
  Show dependency treegraph
Reported: 2012-12-19 21:54 UTC by Ron Johnson
Modified: 2021-10-03 15:29 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:

Spreadsheet that fails. (488.50 KB, application/vnd.ms-excel)
2012-12-19 21:54 UTC, Ron Johnson
bt with symbols on master (17.98 KB, text/plain)
2014-02-09 16:33 UTC, Julien Nabet
console+bt with debug symbols (18.60 KB, text/plain)
2015-05-22 23:58 UTC, Julien Nabet

Note You need to log in before you can comment on or make changes to this bug.
Description Ron Johnson 2012-12-19 21:54:04 UTC
Created attachment 71827 [details]
Spreadsheet that fails.

Problem description: 

Steps to reproduce:
1. Open the relevant xls file

Current behavior:
1. The specified error message pop-up box appears.

Expected behavior:
1. The script works as expected
Operating System: Ubuntu
Version: release
Comment 1 Ron Johnson 2012-12-29 15:55:17 UTC
By marking it as UNCONFIRMED, does that mean that the attached spreadsheet worked for you?
Comment 2 LeMoyne Castle 2013-01-01 02:24:59 UTC
@ Ron, 
The bugzilla system starts all bugs as unconfirmed then with multiple reports or qa reproduction the issue goes to New status.  I added myself to CC: as someone interested in BASIC implementation: I wanted to know if someone else fixed it and to be able to find the bug later (without assigning myself).  

On download+open of spreadsheet I get this warning:
The numbering add-in must be loaded for optimal toolbar and numbering behavior. Please load this add-in to your Library directory.  

then I get the error 23 message. 

Definitely confirmed.  

If LibreOffice BASIC does not implement support the OnSheetActivate event, this could be a compile time error instead of a run-time error.  Certainly the message could be more helpful.  

If these events are supported then that implementation appears broken (or again at least unhelpful).  

Either way, message needs improvement.
Comment 3 Ron Johnson 2013-01-01 04:58:53 UTC
Thanks for the clarification.  :)
Comment 4 Julien Nabet 2014-02-09 16:33:28 UTC
Created attachment 93715 [details]
bt with symbols on master

On pc Debian x86-64 with master sources updated yesterday, I had a crash.
I attached bt + console logs.

(with 4.2 sources I also have got a crash).
Comment 5 Joel Madero 2015-05-02 15:41:43 UTC Comment hidden (obsolete)
Comment 6 Ron Johnson 2015-05-22 15:33:07 UTC
Still present in (88805f81e9fe61362df02b9941de8e38a9b5fd16).
Comment 7 Julien Nabet 2015-05-22 23:58:11 UTC
Created attachment 115866 [details]
console+bt with debug symbols

On pc Debian x86-64 with master sources updated today, I could reproduce this.
I updated the bt but seems quite the same.
Comment 8 Julien Nabet 2015-05-22 23:59:53 UTC
Stephan: could it be a Uno pb (since it appears in bt) or is it completely Basic related?
Comment 9 QA Administrators 2016-09-20 09:41:57 UTC Comment hidden (obsolete)
Comment 10 Buovjaga 2019-08-11 10:46:49 UTC
Still repro

Arch Linux 64-bit
Build ID: 37fc9f51a8de11d40632e8cda17ccf1fa4b1f503
CPU threads: 8; OS: Linux 5.2; UI render: default; VCL: gtk3; 
Locale: fi-FI (fi_FI.UTF-8); UI-Language: en-US
Calc: threaded
Built on 6 August 2019
Comment 11 Ron Johnson 2019-08-11 11:43:19 UTC
It still fails in LibreOffice on Xunbuntu 18.04.
Build ID: 90f8dcf33c87b3705e78202e3df5142b201bd805
CPU threads: 6; OS: Linux 4.15; UI render: default; VCL: gtk2; 
Locale: en-US (en_US.UTF-8); Calc: group threaded

When opening the file, it says macros must be enabled, so I click that button.  Then it fails saying that TMPLTNUM.XLA does not exist.

When I click ok to that, the error message "object not accessible. The object cannot be accessed due to incufficient user rights." appears.

When I click ok to that, it says I must install the numbering add-in needs to be loaded.

When I click ok to that, it shows the original BASIC 423 error.
Comment 12 Stephan Bergmann 2019-08-12 13:46:01 UTC
(In reply to Julien Nabet from comment #8)
> Stephan: could it be a Uno pb (since it appears in bt) or is it completely
> Basic related?

This doesn't appear to be a UNO problem.  Your crash and backtrace from comment 4 and comment 7 appear to be unrelated to the problem described in comment 0 and comment 11.  (And I can reproduce the recipe from comment 11 with a recent local Linux master build.)
Comment 13 Michael Warner 2021-10-03 15:29:10 UTC
Still reproducible in:

Version: (x64) / LibreOffice Community
Build ID: 9a9c6381e3f7a62afc1329bd359cc48accb6435b
CPU threads: 6; OS: Windows 6.1 Service Pack 1 Build 7601; UI render: Skia/Raster; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: threaded