Bug 58559 - libreoffice calc crash when I try to format cells
Summary: libreoffice calc crash when I try to format cells
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.6.4.3 release
Hardware: All Linux (All)
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-20 08:21 UTC by Barto
Modified: 2012-12-20 23:25 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Barto 2012-12-20 08:21:07 UTC
I use archlinux 32 bits,

I notice that libreoffice calc 3.6.4 crashes when I try to format cells,

step to reproduce the bug :

- launch libreoffice
- select a cell
- select the menu "format cells"
- libreoffice calc will crash immediatly ( libreoffice quits with no error message on the console )
Comment 1 Barto 2012-12-20 08:29:23 UTC
I use also KDE 4.9.4
Comment 2 Barto 2012-12-20 08:39:27 UTC
in /var/log/messages.log I can see this :

Dec 20 09:32:36 localhost kernel: [ 1737.952372] soffice.bin[886]: segfault at 1 ip b29b3f66 sp bff622e0 error 4 in libicule.so.50.1.1[b29a4000+3f000]
Comment 3 Julien Nabet 2012-12-20 21:22:25 UTC
Could you retrieve an useful bt (see https://wiki.documentfoundation.org/BugReport#How_to_get_a_backtrace_.28on_Linux.29)?
Comment 4 Barto 2012-12-20 23:25:31 UTC
the problem is fixed with a new archlinux package of libreoffice,

the culprit was the icu lib (package icu 50.1.1-1 ) :

https://bugs.archlinux.org/task/33130