Download it now!
Bug 58579 - EDITING: Changing text language from status bar opens the wrong dialog box
Summary: EDITING: Changing text language from status bar opens the wrong dialog box
Status: CLOSED DUPLICATE of bug 37919
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.4.3 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-20 16:02 UTC by brmj.page
Modified: 2012-12-20 23:08 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description brmj.page 2012-12-20 16:02:23 UTC
Problem description: 
Changing text language from status bar opens the wrong dialog box. This has been happening in all the versions I can remember trying for the last few years, and on all OSs.

Steps to reproduce:
1. Click on current language in the status bar
OR
1. Right-click on current language in the status bar
2. Click on More...
OR
1. Go to Tools -> Language -> For Selection -> More...
OR
1. Go to Tools -> Language -> For Paragraph -> More...

Current behavior:
You get the character formatting box.

Expected behavior:
You should get the Options - Language settings - Languages dialog box.

The only way I can find to get to the right dialog box is through Tools -> Languages -> For all Text -> More...

              
Operating System: All
Version: 3.6.4.3 release
Comment 1 Urmas 2012-12-20 16:24:04 UTC
A Status bar text is intended for the current selection, and therefore opens the corresponding dialog.
Comment 2 brmj.page 2012-12-20 16:47:01 UTC
This is a bug. The dialog box that comes up is that CHARACTER FORMATTING one which has NOTHING to do with the LANGUAGE be it for the whole text or for the current selection.(In reply to comment #1)

> A Status bar text is intended for the current selection, and therefore opens
> the corresponding dialog.
Comment 3 Urmas 2012-12-20 19:44:46 UTC
If you want a separate MS Word–style dialog, make it a corresponding enhancement request. The language is a run property, it belongs in a run formatting dialog, and absolutely doesn't belong in Program Options dialog.
Comment 4 brmj.page 2012-12-20 21:26:24 UTC
I totally agree that if I want to change the language of the current doc, or the current paragraph, or the selected text, I shouldn't be directed to the program options. That is another issue.

The issue that I am reporting is that if I want to change the current paragraph or the selected text to a language that isn't listed in the little menu, I shall click on More... and it sends me to the wrong place.

Have you even tried following the steps to reproduce? I feel like I am talking to a brick wall here. This is the first bug I have reported and the response really isn't encouraging.
Comment 5 manj_k 2012-12-20 22:36:03 UTC
@brmj.page@gmail.com

Please have a look at
Bug 37919 - Clicking "more" on the Language Section in Writer at the bottom bar opens up the wrong Dialog Window
[CLOSED NOTABUG]

See also:
bug 32780, bug 36091, bug 58385.
Comment 6 brmj.page 2012-12-20 22:54:12 UTC

*** This bug has been marked as a duplicate of bug 37919 ***
Comment 7 brmj.page 2012-12-20 23:08:20 UTC
I get your point. None-the-less it is horribly counter-intuitive. I'm filing an enhancement request for a new language selection dialog. See https://bugs.freedesktop.org/show_bug.cgi?id=58591