Bug 58650 - DocumentInfo disappeared
Summary: DocumentInfo disappeared
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: BASIC (show other bugs)
Version:
(earliest affected)
4.0.0.0.beta1
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-22 14:28 UTC by Boudi
Modified: 2013-01-04 14:27 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Boudi 2012-12-22 14:28:00 UTC
ThisComponent.DocumentInfo.EditingCycles

Method not found.

Reproduce:

Sub Main
	print ThisComponent.DocumentInfo.EditingCycles
End Sub
Comment 1 m.a.riosv 2012-12-22 22:08:01 UTC
Hi Boudi, thanks for reporting.

I can not help with this, but you have marked the bug with the severity as blocker.

Please see the blocker bug definition here:
https://wiki.documentfoundation.org/Release_Criteria#Blocker_Bug_Definition
Comment 2 David Tardon 2012-12-23 07:07:22 UTC
The com.sun.star.document.DocumentInfo service had been deprecated since OpenOffice.org 3.0 and has finally been removed in LibreOffice 4.0. You should use com.sun.star.document.DocumentProperties instead.
Comment 3 Boudi 2012-12-23 13:01:26 UTC
Thanks for the advice's.

What way could I have been aware of the deprecation status of com.sun.star.document.DocumentInfo?

So I can try prevent this kind of misunderstanding in the future?
Comment 4 David Tardon 2012-12-25 07:51:35 UTC
I am afraid the only way is to check the IDL files or the generated documentation at http://api.libreoffice.org/docs/common/ref/com/sun/star/module-ix.html
Comment 5 Michael Stahl (allotropia) 2013-01-04 14:23:33 UTC
yes, mainly the @deprecated tags in the generated API reference.

there was also an announcement at the time, though probably few
users read that list:

http://www.mail-archive.com/interface-announce@openoffice.org/msg00432.html
Comment 6 Michael Stahl (allotropia) 2013-01-04 14:27:54 UTC
oh, i forgot: hopefully the release notes list all of the *intentional*
API changes now, my expectation is that for version 4.0 only the Python 3,
DocumentInfo and maybe IllegalArgumentException changes actually
impact API clients in practice:

https://wiki.documentfoundation.org/ReleaseNotes/4.0#API_Changes