Bug 58700 - MAILMERGE: Address Labels 3 column alignment incorrect
Summary: MAILMERGE: Address Labels 3 column alignment incorrect
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.4 release
Hardware: All Linux (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsDevEval
Depends on:
Blocks:
 
Reported: 2012-12-24 06:14 UTC by James Kay
Modified: 2015-12-18 10:26 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
PDF Print of Avery Labels - Please print to label and see if they are aligned (33.90 KB, application/pdf)
2013-06-10 19:19 UTC, Joel Madero
Details

Note You need to log in before you can comment on or make changes to this bug.
Description James Kay 2012-12-24 06:14:50 UTC
Problem description: 
When printing with mailmerge on a sheet of labels with 3 columns, the column spacing is not calculated correctly. Column 1 is more or less OK, but columns 2 and 3 are aligned more and more to the left, so that column 3 does not print on the label. 
Steps to reproduce:
1. Create a mailmerge with a database of addresses to print on labels.
2. Select Avery Letter Size 5160 labels
3. Print and notice above described behavior. 

Current behavior:
As above.
Expected behavior:
I would expect that printing would align the same on labels of all three columns.
              
Operating System: Ubuntu
Version: 3.5.4 release
Comment 1 Joel Madero 2013-06-10 19:18:34 UTC
So I'm not going to go out and purchase the labels but from spot checking, they look right. 

Attaching a pdf print.


@James - can you print the pdf and see if the labels are aligned? If they aren't I'll just say the bug is confirmed.
Comment 2 Joel Madero 2013-06-10 19:19:25 UTC
Created attachment 80638 [details]
PDF Print of Avery Labels - Please print to label and see if they are aligned
Comment 3 Joel Madero 2013-06-10 19:32:48 UTC
Thank you for reporting this issue! I have been able to confirm the issue on:
Version: 4.2.0.0.alpha0+Build ID: b0a1666f756aa5f5315366eca9d7d02ddd55d2b
Date:   Tue May 28 08:51:01 2013 +0300 
Platform: Bodhi Linux 2.2 x64


Nevermind -found some labels - indeed confirmed

Marking as:

New
Major - in general I wouldn't say this but it essentially makes the print to labels useless - I would be surprised if it's not a duplicate somewhere
High - default, seems appropriate

ProposedEasyHack

+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + +
LibreOffice is powered by a team of volunteers, every bug is confirmed (triaged) by human beings who mostly give their time for free. We invite you to join our triaging by checking out this link:
https://wiki.documentfoundation.org/QA/BugTriage and join us on freenode at #libreoffice-qa

There are also other ways to get involved including with marketing, UX, documentation, and of course developing -  http://www.libreoffice.org/get-help/mailing-lists/. 

Lastly, good bug reports help tremendously in making the process go smoother, please always provide reproducible steps (even if it seems easy) and attach any and all relevant material
Comment 4 James Kay 2013-06-10 20:38:42 UTC
I confirmed as well on Avery 5160 template labels (actually Avery 5960, but they use the same template). 

Clever addresses, Joel! :-)
Comment 5 Joel Madero 2013-06-10 20:45:22 UTC
haha I don't get credit for those ;) Found them online just searching "sample data for address labels ;)
Comment 6 Robinson Tryon (qubit) 2013-10-19 00:10:24 UTC
Remove comma from whiteboard.
Comment 7 Joel Madero 2014-02-27 23:03:45 UTC
In order to limit the confusion between ProposedEasyHack and EasyHack and to make queries much easier we are changing ProposedEasyHack to NeedsDevEval.

Thank you and apologies for the noise
Comment 8 Cor Nouws 2014-06-17 11:55:55 UTC
Hi James,

I expect this has been fixed in one of the recent versions.
Can you pls try again?
thanks,
Cor
Comment 9 Alex Thurgood 2015-01-03 17:39:21 UTC
Adding self to CC if not already on
Comment 10 Julien Nabet 2015-02-21 17:56:02 UTC
No feedback since more than 6 months, put it as WFM.

James: don't hesitate to reopen this tracker if you can reproduce it with a recent LO version (last ones are 4.3.5 and 4.4.0)
Comment 11 Robinson Tryon (qubit) 2015-12-18 10:26:28 UTC
Migrating Whiteboard tags to Keywords: (needsDevEval)
[NinjaEdit]