Bug Hunting Session
Bug 58864 - libgnomevfs2-common breaking documents, LibreOffice should avoid the use of this package if available in system
Summary: libgnomevfs2-common breaking documents, LibreOffice should avoid the use of t...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.0.0.0.beta2
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Desktop-Environment
  Show dependency treegraph
 
Reported: 2012-12-29 15:47 UTC by Sérgio Benjamim
Modified: 2018-11-01 14:20 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Do the steps in the description. (158.54 KB, application/vnd.oasis.opendocument.text)
2012-12-29 15:47 UTC, Sérgio Benjamim
Details
Do the steps in the description. (158.54 KB, application/vnd.oasis.opendocument.text)
2012-12-29 16:06 UTC, Sérgio Benjamim
Details
Do the steps in the comment (1.43 MB, application/vnd.oasis.opendocument.text)
2012-12-29 16:21 UTC, Sérgio Benjamim
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sérgio Benjamim 2012-12-29 15:47:05 UTC
Created attachment 72258 [details]
Do the steps in the description.

If libgnomevfs2-common is installed in system, it breaks documents that have formulas and figures. In some cases, after the document is saved and later opened, blank spaces appear in the document.

Steps to reproduce the problem:

- Use Ubuntu 12.04 with Unity desktop
- Install libgnomevfs2-0 (this will instal its dependency, libgnomevfs2-common)
- Open the attachment (Resoluções P4 de Controle Linear - v0.1.odt)
- Go to the second page, click in the line below the formula (the second formula in the document, at the top of the page), make a change and save (add a space for example)
- Close the document, and open it again. There should be a gap between formula and text (a big gap in the truth).

Now, steps to avoid this problem:

- Remove libgnomevfs2-0 and libgnomevfs2-common (apt-get purge libgnomevfs2-0 libgnomevfs2-common)
- Open the document. No more gaps in the document.

I made a video to demonstrate this issue: http://www.youtube.com/watch?v=HqVi54h2-rA

The problem is reproducible in LibreOffice 3.5.4 from official repository and LibreOffice 4.0.0-beta2. The problem also happens in LibreOffice 3.6.4.

LibreOffice should avoid the use of libgnomevfs2-0 and libgnomevfs2-common if available in system. There is not possible to remove these packages in some cases, because some others packages depend on them, as the Inkscape for example.

I tested only in Writer, but the problem must also occur in other modules of LibreOffice.


More information:

Ubuntu 12.04.1 (recent installation and updated), using Unity desktop.
kernel: 3.2.0-35-generic

VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
Comment 1 Sérgio Benjamim 2012-12-29 16:06:16 UTC
Created attachment 72260 [details]
Do the steps in the description.
Comment 2 Sérgio Benjamim 2012-12-29 16:21:30 UTC
Created attachment 72261 [details]
Do the steps in the comment

As was done previously in the other attachment, with the old steps:

- Go to page 6, click in the line below "Questão 2", make a change and save (add a space for example).
- Open the document, there should be only one figure at page 6, and the other figure will be at page 7. Click in the line below "Questão 2", push Enter and do Ctrl+Z three times, the document goes back as it should be.
Comment 3 Joel Madero 2013-01-10 15:13:12 UTC
Marking this as NEW as it's already being worked on (might already be done), scheduled to be disabled on RC1 next week
Comment 4 QA Administrators 2015-02-19 15:39:42 UTC Comment hidden (obsolete)
Comment 5 QA Administrators 2016-02-21 08:37:06 UTC Comment hidden (obsolete)
Comment 6 QA Administrators 2017-03-06 15:44:23 UTC Comment hidden (obsolete)
Comment 7 Xisco Faulí 2017-07-13 09:54:30 UTC
Setting Assignee back to default. Please assign it back to yourself if you're still working on this issue
Comment 8 QA Administrators 2018-07-14 02:46:11 UTC Comment hidden (obsolete)
Comment 9 Thomas Lendo 2018-11-01 14:20:07 UTC
Steps in comment 2 not reproducible anymore.

Version: 6.2.0.0.alpha1+
Build-ID: e33424dd887cb1a11a3dba2513ef0f4bf93a6dbe
CPU-Threads: 4; BS: Linux 4.15; UI-Render: Standard; VCL: gtk3; 
Gebietsschema: de-DE (de_DE.UTF-8); Calc: threaded