Bug 58866 - Export as PDF renders wide glyphs are incorrectly
Summary: Export as PDF renders wide glyphs are incorrectly
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.0.0.beta2
Hardware: Other All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-29 16:53 UTC by Jeff Veit
Modified: 2013-01-07 22:29 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments
Wide glyphs are incorrectly clipped in 4.0.0.0-beta2 (67.94 KB, application/pdf)
2012-12-29 16:53 UTC, Jeff Veit
Details
partridge screencapture from your .pdf test file (5.14 KB, image/png)
2013-01-05 23:52 UTC, tommy27
Details
Doc viewer page 1 (37.37 KB, image/png)
2013-01-06 19:30 UTC, Jeff Veit
Details
Doc viwer page 2 (35.52 KB, image/png)
2013-01-06 19:31 UTC, Jeff Veit
Details
Gimp page 1 (90.36 KB, image/png)
2013-01-06 19:32 UTC, Jeff Veit
Details
Gimp page 2 (94.07 KB, image/png)
2013-01-06 19:32 UTC, Jeff Veit
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jeff Veit 2012-12-29 16:53:28 UTC
Created attachment 72264 [details]
Wide glyphs are incorrectly clipped in 4.0.0.0-beta2

4.0.0.0-beta fixes the rendering problem described in https://bugs.freedesktop.org/show_bug.cgi?id=58862, at the cost of breaking rendering for these glyphs when the text is not centered or tabbed - i.e. normal text. 

Wide glyphs are rendered incorrectly in PDFs; they are clipped incorrectly so that some (about half) the glyph is missing.

I've set this as a major bug because I expect it will affect many fonts, under normal use.

The attached PDF was developed to demonstrate the bug for LibreOffice 3.6, and it shows the bug is fixed by 4.0, but text which rendered correctly in 3.6 is now broken.

(It might be worth checking whether tall glyphs are incorrectly clipped, too.)
Comment 1 tommy27 2013-01-05 23:52:24 UTC
Created attachment 72574 [details]
partridge screencapture from your .pdf test file

tested on Vista 64bit using Adobe Acrobat 8

sorry but I do not see anything wrong in the test .pdf file you uploaded...

for example, you say that "It should look like a partridge but the body and head are missing" but I see the entire bird with no missing parts... see attached screenshot.

which PDF Reader do you use?
Comment 2 Jeff Veit 2013-01-06 19:30:45 UTC
Created attachment 72595 [details]
Doc viewer page 1
Comment 3 Jeff Veit 2013-01-06 19:31:22 UTC
Created attachment 72596 [details]
Doc viwer page 2
Comment 4 Jeff Veit 2013-01-06 19:32:08 UTC
Created attachment 72597 [details]
Gimp page 1
Comment 5 Jeff Veit 2013-01-06 19:32:48 UTC
Created attachment 72598 [details]
Gimp page 2
Comment 6 Jeff Veit 2013-01-06 19:38:53 UTC
Doc viewer = Evince 3.6.0 - http://projects.gnome.org/evince/
Gimp = Gimp 2.8.2

The Evince pngs are screenshots captured by Gimp. The Gimp pngs are the test PDF loaded directly into Gimp then saved as png.

Are you seeing the same errors? If not, I'm imagining that it's not a bug in LibreOffice, but a bug in a library that's common to Gimp and Evince.
Comment 7 Jeff Veit 2013-01-06 19:45:36 UTC
And the common library would be Poppler. http://poppler.freedesktop.org/
Comment 8 Jeff Veit 2013-01-06 23:34:56 UTC
But interestingly, Abiword renders PDF tests better; the partridge isn't cut in half. But I think that Abiword uses Poppler too.
Comment 9 Urmas 2013-01-07 22:29:28 UTC
I don't see clipping shown on your screenshots in the PDF file. Do not use freetarded software next time.