Bug Hunting Session
Bug 58878 - Certain customized control keybindings don't work
Summary: Certain customized control keybindings don't work
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.6.4.3 release
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-30 03:52 UTC by Robert Nikander
Modified: 2015-03-25 16:59 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Nikander 2012-12-30 03:52:10 UTC
I went to the "Tools" menu, "Customize...", "Keyboard".  I select a shortcut key marked as ^C (control + C).  I map it to a function, click "Modify" and "OK".  Hitting Control-C in Writer does nothing, or just inserts the letter "c".  I tried various commands, like setting a style and Insert Date, and other control bindings like ^D, ^9. None of them work.  If I bind to something else, like Command-Shift-C, everything works as expected.
Comment 1 Jorendc 2012-12-30 19:36:47 UTC
Thanks for reporting!

I can reproduce, but there are some OS-related keyboard shortcuts: https://support.apple.com/kb/ht1343

When you press one of these, LibreOffice can never get the interrupt from the keyboard, because Mac OSX picks it up.

So, ctrl+C isn't a OSX keyboard shortcut so normally we can use this... I tested it, and there is indeed a problem.

ctrl+D is already occupied: "Control-D Delete the character in front of the cursor", so we can't use it in LibreOffice...

I also tested the F-keys (F4), I have no problem with that. When binding a function to it, it'll execute that function properly when pressed.
Comment 2 QA Administrators 2015-01-05 17:51:50 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (4.3.5 or later): https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior

If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

Thank you for your help!

-- The LibreOffice QA Team
Comment 3 Alex Thurgood 2015-03-25 13:52:20 UTC
Changing title to reflect findings of comment 1
Comment 4 Alex Thurgood 2015-03-25 15:44:05 UTC
However, given Joren's comment in comment 1, I don't see why we should support overriding OSX system keyboard shortcuts. What would the rationale for that be ?

I would be tempted to mark this as either NOTOURBUG or WONTFIX
Comment 5 Alex Thurgood 2015-03-25 15:51:28 UTC
Still present in 4500 alpha master build
Comment 6 Robert Nikander 2015-03-25 16:15:15 UTC
I can't test this again now, but when I reported the bug, it was for key combinations like Control-C, which is not an OS X shortcut, normally.
Comment 7 Alex Thurgood 2015-03-25 16:34:59 UTC
(In reply to Robert Nikander from comment #6)
> I can't test this again now, but when I reported the bug, it was for key
> combinations like Control-C, which is not an OS X shortcut, normally.

Yes, you are correct, sorry. At present, I tried to recreate a new keyboard shortcut to insert a sheet into a Calc document, but I don't seem to be able to change any of the pre-proposed keyboard combos in the list, even the ones without a function attribution. I don't see ^C anywhere in the list of proposed shortcuts, either generally for LO as a whole, or for Calc as a specific app.


Version: 4.4.1.2
Build ID: 45e2de17089c24a1fa810c8f975a7171ba4cd432
Locale : fr_

So, where, if anywhere, do you see the ^C shortcut ? If it has been removed, then this is no longer a bug as other key combos work.
Comment 8 Alex Thurgood 2015-03-25 16:36:56 UTC
I don't see ^C in Writer keyboard customisation either, among the possible choices.
Comment 9 Robert Nikander 2015-03-25 16:52:05 UTC
I don't have LibreOffice installed any more (I survive with iWork), so I can't say  whether this is still a bug. It's up to you.
Comment 10 Alex Thurgood 2015-03-25 16:59:41 UTC
OK, so closing, as ^C is no longer proposed as a shortcut, or any keyboard combo using just ^ + another key for that matter.