Download it now!
Bug 58990 - EXTENSIONSWEBSITE: Enhanced localization selector required
Summary: EXTENSIONSWEBSITE: Enhanced localization selector required
Status: RESOLVED MOVED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: WWW (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: lowest enhancement
Assignee: Not Assigned
URL: http://extensions.libreoffice.org/
Whiteboard:
Keywords:
Depends on:
Blocks: 58991
  Show dependency treegraph
 
Reported: 2013-01-03 18:17 UTC by Rainer Bielefeld Retired
Modified: 2015-10-17 20:34 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2013-01-03 18:17:09 UTC
Before work on "Bug 58989 - Transfer additional info to EXTENSIONSWEBSITE" can start we need an enhanced forward mechanism what forwards links to localizations what do not exist to English language. Without that wor on that bug would be rather useless.
Comment 1 Rob Snelders 2013-01-03 23:05:58 UTC
when I try http://extensions.libreoffice.org/?set_language=nl then it defaults to the English language. So I don't think I understand the problem?

Can you please explain.
Comment 2 Rainer Bielefeld Retired 2013-01-04 05:59:46 UTC
@Rob Snelders:
I can't reproduce your observations, with some nonsense-localizations like <www.extensions.libreoffice.org/?set_language=zz> as a bookmark I reached the German localization of the site, not the English one. But when I modify "set_language=cs" to "set_language=zz" in the browser URL pane, view switches to the English localization.

Nevertheless, the result is the same, you do not reach nirvana with a link to a not existing localization, but a real web page where you can select an existing localization. So we currently we do not have a real problem here, I will do some further investigation and think about it, may be we can close the report for now.
Comment 3 Rob Snelders 2013-01-04 23:35:48 UTC
I still don't experience your problem. But what I see is another problem. We have for portugese (Brizilian) pt-br. But other languages are only 2 chars long. So it is impossible to be able to have both. We should then OR remove the brazilian or always accept the complete locale otherwise it would be a nightmare to sort this in LibreOffice.
Comment 4 Rainer Bielefeld Retired 2013-01-05 08:20:20 UTC
@Rob:
There is no real problem, only some things I do not understand (or what are unexpected)
So this one is more or less only still active because there might appear unexpected (or difficult to handle) aspects aus you found and what might have influence at many places (Website, LibO UI, LibO Localization, ...).

This "pt-br" problem is the same for "Chinese (simplified)", Chinese (traditional) at international sites, and may be additional ones as we see in Extension repository (it-it, es-es, hu-hu). We urgently need some unification here.

@Sophie, @András:
Can you help with some advice?
Comment 5 Marc Pare 2013-02-10 11:50:36 UTC
Just checking on this bug to see if it has been resolved? It sits as unconfirmed. Do we change its status?

Marc
Comment 6 Rob Snelders 2013-02-12 22:39:24 UTC
the problem still persists. So setting it to NEW
Comment 7 Dennis Roczek 2015-10-17 20:34:54 UTC
ticket moved to redmine https://redmine.documentfoundation.org/issues/1524