Bug 58997 - XML import into Calc fails
Summary: XML import into Calc fails
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
(earliest affected)
3.5.4 release
Hardware: Other other
: medium normal
Assignee: Not Assigned
Depends on:
Reported: 2013-01-03 21:27 UTC by Jules Lauwerier
Modified: 2014-08-06 13:25 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Note You need to log in before you can comment on or make changes to this bug.
Description Jules Lauwerier 2013-01-03 21:27:49 UTC
XML import into Calc fails with general error ("Algemene fout. Algemene invoer-/uitvoer fout").

I am trying to use the most simple example at http://forum.openoffice.org/en/forum/viewtopic.php?f=45&t=3490. I managed to create the import-filter. 

When I use File - Open (Bestand - Openen), I can select the filter "Payments (.xml)" and the datafile "payments.xml".

Then it immediately fails with the error message in a popup: "Algemene fout. Algemene invoer-/uitvoerfout." (meaning "General error. General I/O-error").

I am using Kubuntu with LibreOffice (dutch)
Comment 1 Jorendc 2013-05-19 19:01:57 UTC
Hi Jules,

In Dutch (mine and reporters native language): Zou je dit nog eens opnieuw kunnen proberen met een nieuwere LibreOffice versie (

In English: Is this still reproducible using more recent versions of LibreOffice (like

Thanks for retesting,

PS: please reply in English (and Dutch if you like). I only replied in Dutch because I don't see that many Dutch bug reporters ;-).
Comment 2 bfoman (inactive) 2013-07-08 13:19:58 UTC
Please answer question from comment 1.
Comment 3 Jules Lauwerier 2013-07-08 21:14:08 UTC
I will reply in English to avoid that other people can't follow this thread anymore.

I am now using LibreOffice I just tried the example again. Still the same error message.

Comment 4 QA Administrators 2014-02-02 02:06:32 UTC
Dear Bug Submitter,

Please read the entire message before proceeding.

This bug has been in NEEDINFO status with no change for at least 6 months. Please provide the requested information as soon as possible and mark the bug as UNCONFIRMED. Due to regular bug tracker maintenance, if the bug is still in NEEDINFO status with no change in 30 days the QA team will close the bug as INVALID due to lack of needed information.

For more information about our NEEDINFO policy please read the wiki located here: 

If you have already provided the requested information, please mark the bug as UNCONFIRMED so that the QA team knows that the bug is ready to be confirmed.

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team
Comment 5 Jules Lauwerier 2014-02-02 08:10:11 UTC
still fails with Libre?Office
Comment 6 Robinson Tryon (qubit) 2014-02-04 15:04:17 UTC
(In reply to comment #5)
> still fails with Libre?Office

Hiya, is now out -- could you please try with that version as well?

Comment 7 retired 2014-07-25 08:26:23 UTC
Is this bug still valid / reproducible with the latest LO release?
4.3RC3: http://www.libreoffice.org/download/pre-releases/

Please also try resetting your user profile and let us know if that helps: https://wiki.documentfoundation.org/UserProfile

Should this be still reproducible for you with the latest LO release please set this bug back to UNCONFIRMED. Should this issue be solved set it to WORKSFORME.

Setting to NEEDINFO until more detail is provided.

Also please provide a test file to test this behavior with. Otherwise it will be impossible to reproduce.
Comment 8 Maxim Monastirsky 2014-08-06 13:25:52 UTC
WORKSFORME with (ea596d69054bca96ac15fa46631c42422e859b19) under Fedora 20. Feel free to reopen if it's still reproducible for you with 4.3/master.