Download it now!
Bug 59030 - UI: the line colour and area style/filling dropdowns on the formatting menu do not work correctly with the default rectangles
Summary: UI: the line colour and area style/filling dropdowns on the formatting menu d...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.0.0.beta2
Hardware: All Windows (All)
: low trivial
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-04 17:11 UTC by john.pratt
Modified: 2016-10-06 07:18 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description john.pratt 2013-01-04 17:11:40 UTC
Problem description:
A. When a rectangle is created using the 'rectangle' button from the draw toolbar the line colour is not displayed on the formatting toolbar when the rectangle is selected.
B. When a rectangle is created using the 'basic shapes -> rectangle' option from the draw toolbar the line colour is not displayed on the formatting toolbar and neither is the area style/filling, when the rectangle is selected.

Steps to reproduce (A):
A1. Open a new writer document.
A2. Create a rectangle using the 'rectangle' tool from the 'drawing' toolbar.

A: Current behaviour: the 'line colour' box is blank or does not update.

A: Expected behaviour: the 'line colour' box should display the current line colour.

Steps to reproduce (B):
B1. Open a new writer document.
B2. Create a rectangle using the 'basic shapes → rectangle' tool from the 'drawing' toolbar.

B: Current behaviour: the 'line colour' box is blank or does not update and the 'area style/filling' box is also blank or does not update.

B: Expected behaviour: the 'line colour' box should display the current line colour and the 'area style/filling' box should display the correct fill colour.

NB: if the colours are changed, then this works as expected; the problem only seems to exist with default shapes.
Operating System: Windows XP
Version: 4.0.0.0.beta2
Comment 1 Regina Henschel 2013-01-05 22:18:08 UTC
Please have a look, whether this toolbar is somewhere at the right side of the standard toolbar. It seems to me, that the initial position is sometimes wrong.
Comment 2 john.pratt 2013-01-08 16:52:49 UTC
For me the toolbar is always in the correct state, but the state of the dropdowns is not always correct with the default shapes.
Comment 3 Jorendc 2013-01-11 22:09:33 UTC
Thanks for reporting (I can't say that enough; I see a lot of reports passing by from you). Good work!

I can confirm using Windows 7 x64, LibreOffice Version 4.0.0.1 (Build id: 527dba6f6e0cfbbc71bd6e7b88a52699bb48799).

The box of the 'line color' is blank.
Comment 4 Jorendc 2013-01-11 22:18:48 UTC
Set bug priority/importance to:

'trivial' and 'low', because this bug doesn't resolve in a crash/data loss; nor it prevent you to make professional high quality work and doesn't make it 'substantial' harder (the chance you need to alter the line color, other than black, is low + it's easy to change color if you need to (only no preset value)). I hope you can agree with this importance triaging.(source of this decision: https://wiki.documentfoundation.org/images/0/06/Prioritizing_Bugs_Flowchart.jpg)
Comment 5 john.pratt 2013-01-12 11:00:03 UTC
@Joren De Cuyper
I'm happy with that triaging - it is not a big problem - just a slight irritation.
Comment 6 Rainer Bielefeld Retired 2013-01-24 12:43:58 UTC
I can't reproduce a area color problem.

Reason for the problem might be that the lines color defined in "Default" style is without name? When I modify line color to "light red" in default style everything works fine, when I reset Defaule Style default line color to "Default" the problem reappears.

The Line problem also is reproducible for "old style shapes" circle and ellipse:
Already  [Reproducible] with parallel installation of  "LOdev  4.0.0.0.beta1   -  GERMAN UI / German Locale  [Build ID: 87906242e87d3ddb2ba9827818f2d1416d80cc7)]"  {tinderbox: @6, pull time 2012-12-06} on German WIN7 Home Premium (64bit) with separate /4 User Profile for Master Branch

Was still ok with
*  unzipped  installation of  "LOdev  4.0.0.0.alpha1+   -  ENGLISH UI / German Locale  [Build ID: af60316514f3ae3d4c475819bf86f2af837171e)]"  {tinderbox: Win-x86@6, pull time 2012-11-23 22:10:31} on German WIN7 Home Premium (64bit) with own separate User Profile
Comment 7 John Hart 2013-05-22 12:18:27 UTC
Downloaded latest LO yesterday.  Went to use and found that the pull down menus are black with not text and clicking on them does nothing.  I presume I am using 4.0.3.3 as it was downloaded from the PPA on 2013.05.21.  This occurs on Writer, Spreadsheet, Drawing, and the rest of the subparts of LO.  The affected is the menu bar pulldowns  such as Help, Tooks, and so on.  

The problem makes LO almost unusable.
Comment 8 Jorendc 2013-05-22 22:23:36 UTC
(In reply to comment #7)
> Downloaded latest LO yesterday.  Went to use and found that the pull down
> menus are black with not text and clicking on them does nothing.  I presume
> I am using 4.0.3.3 as it was downloaded from the PPA on 2013.05.21.  This
> occurs on Writer, Spreadsheet, Drawing, and the rest of the subparts of LO. 
> The affected is the menu bar pulldowns  such as Help, Tooks, and so on.  
> 
> The problem makes LO almost unusable.

This is another bug, and is already reported and fixed (see bug 63840). An update should fix this problem. Please report different bugs as a different bug report. I'll revert your changes.

Kind regards,
Joren
Comment 9 QA Administrators 2015-03-04 02:22:59 UTC Comment hidden (obsolete)
Comment 10 Buovjaga 2015-03-24 14:07:19 UTC
I confirm that the line color stays black, but area color is correctly Tango: sky blue 1.

Win 7 Pro 64-bit, LibO Version: 4.4.1.2
Build ID: 45e2de17089c24a1fa810c8f975a7171ba4cd432
Locale: fi_FI
Comment 11 QA Administrators 2016-09-20 10:29:42 UTC Comment hidden (obsolete)
Comment 12 Chris Cameron 2016-10-05 22:35:33 UTC
Can confirm that the line colour box remains black, as described in the original report.

The fill colour box does show the correct colour, as mentioned in other comments.


Operating system: OS X 10.11.6
Version: 5.2.1.2
Comment 13 Maxim Monastirsky 2016-10-06 07:18:40 UTC
There is some confusion here. The original report was about the line color box being *blank* - i.e. empty - not showing any color. And there was indeed such bug several years ago IIRC, when the line color button was still a combobox, rather than a color palette like now. This bug isn't present anymore -> WORKSFORME.

But comment 10 and comment 12 "confirmed" that the line color button is (initially) *black*, and that's another issue, already addressed in Bug 90721.

(And the line color button isn't supposed to change its color according to the currently selected shape, as it's a split button meant to easily reuse the last selected color, see https://wiki.documentfoundation.org/ReleaseNotes/4.3#Color_pickers_improvements)