Bug 59055 - UI: Asian font names are in English, not in native language (regression)
Summary: UI: Asian font names are in English, not in native language (regression)
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Localization (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: Other Linux (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-05 14:08 UTC by webofht-libreofficebugs002
Modified: 2016-04-24 20:03 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Font names not in target language (209.70 KB, application/vnd.oasis.opendocument.graphics)
2013-01-05 14:08 UTC, webofht-libreofficebugs002
Details
Screenshots in LibreOffice 4.0.0.3 and 3.6.4.3 (324.22 KB, application/vnd.oasis.opendocument.graphics)
2013-02-03 13:33 UTC, webofht-libreofficebugs002
Details
Screenshots showing the font names in LibreOffice 3 and 4 (557.68 KB, application/vnd.oasis.opendocument.graphics)
2013-02-12 01:53 UTC, webofht-libreofficebugs002
Details
screen shot for the Chinese font name in Chinese language also. (95.34 KB, image/png)
2013-07-01 02:06 UTC, Flex Liu
Details
Chinese font name not display in Chinese in alpha version (103.97 KB, image/png)
2013-07-01 02:19 UTC, Flex Liu
Details

Note You need to log in before you can comment on or make changes to this bug.
Description webofht-libreofficebugs002 2013-01-05 14:08:50 UTC
Created attachment 72542 [details]
Font names not in target language

Problem description: Font names are shown in the target language in LibreOffice version  3.6.3.2 (Build ID: 58f22d5). In LibreOffice version 4.0.0.0.beta2 (Build ID: 4104d660979c57e1160b5135634f732918460a0), Chinese font names are not shown in Chinese. Japanese font names are not shown in Japanese. This is a software regression.

Steps to reproduce:
1. The operating system used is Linux debian 2.6.32-5-686 #1 SMP Sun Sep 23 09:49:36 UTC 2012 i686 GNU/Linux.
2. Start LibreOffice Writer or Calc.
3. Have a look at the font names.
4. Chinese font names are in English. Japanese font names are in English.

Current behavior: The font names are not shown in the target language.

Expected behavior: The font names should be shown in the target language.

I am submitting the screenshots.

Regards,
C. H. D.

Operating System: Debian
Version: 4.0.0.0.beta2
Last worked in: 3.6.3.2 release
Comment 1 Joel Madero 2013-01-10 17:47:45 UTC
This will be fixed by stable release. A ton of localization stuff gets handled between Beta 2 and stable release. You should see some of these improvements in RC1 being released next week.

Closing the bug as NOTABUG because this is expected, Beta's don't have localization done. 

If you still see this in stable release next month please reopen the bug but I expect that you won't :)

Thanks for your help in finding bugs
Comment 2 webofht-libreofficebugs002 2013-02-02 06:47:33 UTC
(In reply to comment #1)
> This will be fixed by stable release. A ton of localization stuff gets
> handled between Beta 2 and stable release. You should see some of these
> improvements in RC1 being released next week.
> 
> Closing the bug as NOTABUG because this is expected, Beta's don't have
> localization done. 
> 
> If you still see this in stable release next month please reopen the bug but
> I expect that you won't :)
> 
> Thanks for your help in finding bugs

The font names are not in the target language in LibreOffice version 4.0.0.3 (Build ID: 7545bee9c2a0782548772a21bc84a9dcc583b89).

Maybe, localization is still in progress.
Comment 3 Urmas 2013-02-02 09:27:20 UTC
Font names have nothing to do with localization.
Comment 4 webofht-libreofficebugs002 2013-02-03 13:33:24 UTC
Created attachment 74132 [details]
Screenshots in LibreOffice 4.0.0.3 and 3.6.4.3

The screenshots are taken on Debian Linux.
Comment 5 webofht-libreofficebugs002 2013-02-11 12:48:28 UTC
Asian font names are still in English, but not in the native language, e.g. Chinese and Japanese.

$ cat /opt/libreoffice4.0/program/versionrc
[Version]
AllLanguages=en-US
BuildVersion=
buildid=7545bee9c2a0782548772a21bc84a9dcc583b89
ExtensionUpdateURL=http://updateexte.libreoffice.org/ExtensionUpdateService/check.Update
ProductBuildid=103
ProductMajor=400
ProductMinor=0
ProductSource=OOO400
ReferenceOOoMajorMinor=3.4
UpdateID=LibreOffice_4_en-US
UpdateURL=http://update.libreoffice.org/check.php?pkgfmt=deb
UpdateUserAgent=<PRODUCT> (${buildid}; ${_OS}; ${_ARCH}; BundledLanguages=${AllLanguages})
Vendor=The Document Foundation
Comment 6 Jiero 2013-02-11 17:30:15 UTC
Sure it shall accomplish to the language of your choice.

Locale set as:
AllLanguages=en-US

Why would you expect LibreOffice show unknown symbols to en-US user?
Comment 7 webofht-libreofficebugs002 2013-02-12 01:53:08 UTC
Created attachment 74662 [details]
Screenshots showing the font names in LibreOffice 3 and 4

(In reply to comment #6)
> Sure it shall accomplish to the language of your choice.
> 
> Locale set as:
> AllLanguages=en-US
> 
> Why would you expect LibreOffice show unknown symbols to en-US user?

Someone is monolingual. Someone is multilingual. The users are not necessarily expected to be monolingual.

LibreOffice 3 shows both the English version and the Chinese or Japanese version of font names.

LibreOffice 4 shows only the English version of font names.

Setting the locale to Chinese (traditional) does not help to display the Chinese version of font names in LibreOffice 4. Font names are still in English.

Regards,

C. H. D.
Comment 8 Rainer Bielefeld Retired 2013-02-17 12:13:35 UTC
NOT reproducible as regression compared to 3.6 with  "LibreOffice 3.6.5.2 " German UI/ German Locale [Build-ID: 5b93205] {pull date 2013-01-18} on German WIN7 Home Premium (64bit) 

And I am rather astonished to see somehow chinese fontnames in an English UI?

@webofht-libreofficebugs002
Can you please gain screenshots into 1 document and obsolete the other ones? Currently your screenshots are very worrying for me
Comment 9 webofht-libreofficebugs002 2013-02-17 15:49:56 UTC
(In reply to comment #8)
> @webofht-libreofficebugs002
> Can you please gain screenshots into 1 document and obsolete the other ones?
> Currently your screenshots are very worrying for me

Comment 7 has shown the screenshots. I do not know what to add (?).
Comment 10 Thomas van der Meulen 2013-02-25 16:05:47 UTC
Thank you for reporthing this bug,
I can reproduce this bug running LibreOffice 4.0.1.1 rc (EN) with Chinese languagepack on Ubuntu 12.10_EN.
Comment 11 Flex Liu 2013-06-17 05:09:51 UTC
I have tested with Libreoffice Version 4.0.3.3 (Build ID: 0eaa50a932c8f2199a615e1eb30f7ac74279539) already, and could not reproduce this issue, Chinese Font name display in Chinese also. so I think this issue been fixed in upstream already.
Comment 12 webofht-libreofficebugs002 2013-06-19 02:53:36 UTC
$ cat /opt/libreoffice4.0/program/versionrc
[Version]
AllLanguages=en-US
BuildVersion=
buildid=0eaa50a932c8f2199a615e1eb30f7ac74279539
ExtensionUpdateURL=http://updateexte.libreoffice.org/ExtensionUpdateService/check.Update
ProductBuildid=3
ProductMajor=400
ProductMinor=0
ProductSource=OOO400
ReferenceOOoMajorMinor=3.4
UpdateID=LibreOffice_4_en-US
UpdateURL=http://update.libreoffice.org/check.php?pkgfmt=deb
UpdateUserAgent=<PRODUCT> (${buildid}; ${_OS}; ${_ARCH}; BundledLanguages=${AllLanguages})
Vendor=The Document Foundation


I am afraid that the Chinese font names are still in English.
Comment 13 webofht-libreofficebugs002 2013-06-19 02:54:34 UTC
I use

$ uname -a
Linux debian 3.2.0-4-amd64 #1 SMP Debian 3.2.46-1 x86_64 GNU/Linux
Comment 14 Flex Liu 2013-07-01 02:06:29 UTC
Created attachment 81772 [details]
screen shot for the Chinese font name in Chinese language also.

cat /opt/libreoffice4.0/program/versionrc
[Version]
AllLanguages=en-US
BuildVersion=
buildid=9e9821abd0ffdbc09cd8c52eaa574fa09eb08f2
ExtensionUpdateURL=http://updateexte.libreoffice.org/ExtensionUpdateService/check.Update
ProductBuildid=2
ProductMajor=400
ProductMinor=0
ProductSource=OOO400
ReferenceOOoMajorMinor=3.4
UpdateID=LibreOffice_4_en-US
UpdateURL=http://update.libreoffice.org/check.php?pkgfmt=rpm
UpdateUserAgent=<PRODUCT> (${buildid}; ${_OS}; ${_ARCH}; BundledLanguages=${AllLanguages})
Vendor=The Document Foundation

I just upgrade to 4.0.4.2, and still not produce the issue.
Comment 15 Flex Liu 2013-07-01 02:19:37 UTC
Created attachment 81773 [details]
Chinese font name not display in Chinese in alpha version

cat versionrc
[Version]
AllLanguages=en-US
BuildVersion=
buildid=55e74e06ffae30b9d01fa24fd1668d8816ee2500
ExtensionUpdateURL=http://updateexte.libreoffice.org/ExtensionUpdateService/check.Update
ProductMajor=420
ProductMinor=0
ReferenceOOoMajorMinor=3.4
UpdateID=LibreOffice_4_en-US
UpdateURL=
UpdateUserAgent=<PRODUCT> (${buildid}; ${_OS}; ${_ARCH}; BundledLanguages=${AllLanguages})
Vendor=root

I also test the git alpha version, it could reproduced.
Comment 16 webofht-libreofficebugs002 2013-07-02 13:18:16 UTC
In Version 4.0.4.2 (Build ID: 9e9821abd0ffdbc09cd8c52eaa574fa09eb08f2),

Chinese font names are in English, not Chinese.
Comment 17 Flex Liu 2013-08-19 06:22:30 UTC
It is a fontconfig relate issue,

I could reproduce the issue with fontconfig-2.10.2-2.2.1
and could not reproduce the issue with fontconfig-2.8.0-24.17.1
Comment 18 retired 2014-12-11 10:37:40 UTC
Is this persisting with LO 4.4b2?
https://www.libreoffice.org/download/pre-releases/

Sorry, no chinese fonts on my system here.
Comment 19 Matthew Francis 2015-02-12 06:12:45 UTC
Still occurs on Ubuntu 14.04, LibreOffice 4.4.0.3 with desktop UI locale and LO language set to Chinese
Comment 20 Robinson Tryon (qubit) 2015-03-31 16:24:33 UTC
(In reply to Flex Liu from comment #17)
> It is a fontconfig relate issue,
> 
> I could reproduce the issue with fontconfig-2.10.2-2.2.1
> and could not reproduce the issue with fontconfig-2.8.0-24.17.1

So is this even our bug?
Comment 21 Joel Madero 2015-03-31 18:26:05 UTC
Given that info - no :) Closing as NOTOURBUG. Please report with the appropriate people against that package.
Comment 22 Jean-Baptiste Faure 2016-04-24 20:03:18 UTC
Version set from description.

if NotOurBug then not a LibreOffice regression -> regression keyword removed

Best regards. JBF