Bug Hunting Session
Bug 59138 - FORMATTING: Changing background color of a table cell makes DRAWING forget the border formatting
Summary: FORMATTING: Changing background color of a table cell makes DRAWING forget th...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
3.6.4.3 release
Hardware: Other Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-08 15:47 UTC by volker.nebelung
Modified: 2015-03-08 19:05 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description volker.nebelung 2013-01-08 15:47:49 UTC
Problem description: 

When you edit the background color of a table cell, clicking OK and applying the change makes the cell lose all its border formatting. Even when you explicitly check some borders to appear immediately after you changed the background color and then click OK, the border formatting is lost.

Steps to reproduce:
1. Create a new table
2. Right click in a cell and choose "Table…"
3. Choose tab "Borders" and select some borders
4. Click "OK"
5. Right click again in the same cell "Table…"
6. Choose tab "Background" and change the color
7. Go to tab "Borders" and see that the current border is yet selected
8. Click "OK" --> border disappears

Current behavior:

Border formatting is getting lost on editing cell background color

Expected behavior:

Border formatting should be unaffected by changing the cell's background color
Operating System: Mac OS X
Version: 3.6.4.3 release
Comment 1 m.a.riosv 2013-01-09 00:29:24 UTC
Hi @volker, thanks for reporting.

I have did a try, seems to me the issue is that border are removed when a background colour is applied. If after set the background colour the border is set up then it remains.

At least there is a easy work around.

Set as new.
Comment 2 QA Administrators 2015-02-19 15:45:31 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.0.3 or later): https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior

If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

Thank you for your help!

-- The LibreOffice QA Team
This NEW Message was generated on: 2015-02-19
Comment 3 Buovjaga 2015-03-08 19:05:28 UTC
Not a problem anymore -> WFM.

Win 7 Pro 64-bit, LibO Version: 4.4.1.2
Build ID: 45e2de17089c24a1fa810c8f975a7171ba4cd432
Locale: fi_FI

Ubuntu 14.10 64-bit 
Version: 4.4.1.2
Build ID: 40m0(Build:2)
Locale: en_US