Bug Hunting Session
Bug 59148 - Writer does not open a dotx file correctly.
Summary: Writer does not open a dotx file correctly.
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.4.3 release
Hardware: x86 (IA32) All
: high normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-09 01:26 UTC by Jared
Modified: 2018-02-20 16:46 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
DOTX template file with protected header and footer content (32.20 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.template)
2013-01-09 01:26 UTC, Jared
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jared 2013-01-09 01:26:31 UTC
Created attachment 72693 [details]
DOTX template file with protected header and footer content

My organization has provided ".dotx" files as a template for me to use, but I cannot open it correctly rendered in LibreOffice 3.6.4 or LO-dev 4.0 Beta 2. I've tried this in OpenSUSE 12.1 and Windows 8.

*Essentially the header and footer are protected fields created in Word 2010 with graphics and text, and the body is open for text, but supposedly with limitations of manipulation.

When I open the file I have a page that looks blank with a field to type in, but the header and footer seem stripped out, and I can manipulate more than I think I am supposed to.

If from MS Word I save the file as a "doc" and then work from there-- it mostly works.  It preserves the content and formatting of the header and footer 90% (margins are off a little).  However when in LibreOffice the protections built-in from Word formatting restrictions are not applied.

A Nabble thread referencing this is here:

http://nabble.documentfoundation.org/Unable-to-use-dotx-files-tp4027691p4027872.html

Thank you!
Comment 1 Jorendc 2013-02-01 00:24:52 UTC
I can reproduce this problem using Mac OSX 10.8.2 and Linux Mint 14 x64. Both tested with LibreOffice 4.0.0.2 rc2.

I also verified the document using Word for Mac 2011; There the document has indeed a header and footer.

Therefore I mark this as NEW.

Following [1] I mark this as 'Medium' but 'high'.

Kind regards,
Joren

[1] https://wiki.documentfoundation.org/images/0/06/Prioritizing_Bugs_Flowchart.jpg
Comment 2 QA Administrators 2015-02-19 15:33:22 UTC Comment hidden (obsolete)
Comment 3 Jared 2015-02-25 22:53:11 UTC
This document does still not render correctly for me on version 4.4.1.1
I am running Windows 10 tech preview 64-bit.
Comment 4 Jared 2015-06-23 17:39:25 UTC
This is still broken in 5.0.0.1 (x86 build), running on Win10 Preview 10130, 64-bit.
Comment 5 QA Administrators 2016-09-20 10:09:49 UTC Comment hidden (obsolete)
Comment 6 Jared 2017-07-27 19:06:08 UTC
I am running 5.4.0.1 and the document MOSTLY renders correctly. I think some spacing is still off in the header.
This is not entirely broken, but improved, since the bug was originally filed.
Comment 7 Jared 2018-02-20 16:46:49 UTC
I am now using 6.0.1.1 (x64) and happy with the usability currently exists.