Bug Hunting Session
Bug 59170 - Synonym suggestion not working with Umlauts
Summary: Synonym suggestion not working with Umlauts
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Linguistic (show other bugs)
Version:
(earliest affected)
3.6.3.2 release
Hardware: All Linux (All)
: high normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-09 16:39 UTC by Samuel Mehrbrodt (CIB)
Modified: 2016-12-19 15:32 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Suggestions by Thesaurus (16.91 KB, image/png)
2013-01-09 16:39 UTC, Samuel Mehrbrodt (CIB)
Details
Screenshot Mac OS X 10.8.2; LibreOffice 4.0 RC1 (30.50 KB, image/png)
2013-01-14 18:58 UTC, Jorendc
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Samuel Mehrbrodt (CIB) 2013-01-09 16:39:15 UTC
Created attachment 72730 [details]
Suggestions by Thesaurus

See attached screenshot. German umlauts are replaced with a '?' in the Synonyms suggestions, maybe this is the case for all non-ASCII chars.
Comment 1 Jorendc 2013-01-14 18:58:53 UTC
Created attachment 73017 [details]
Screenshot Mac OS X 10.8.2; LibreOffice 4.0 RC1

Can't reproduce that using Mac OSX 10.8.2 with LibreOffice Version 4.0.0.1 (Build ID: 527dba6f6e0cfbbc71bd6e7b88a52699bb48799)
TinderBox: MacOSX TDF Release, Branch:libreoffice-4-0, Time: 2013-01-09_10:49:53
Comment 2 Samuel Mehrbrodt (CIB) 2013-01-16 15:10:10 UTC
I just built Master again (I192671cdec129b7c78638efb0c4339bfb265c47d) and I still have this bug. 

Can someone test this on Linux please?
Comment 3 Joel Madero 2013-01-17 16:48:23 UTC
Confirmed on 3.6.3.2 on Bodhi Linux.

Changing version.
@reporter - version reflects oldest version that the bug is seen on, we use comments to say "we tested and confirmed on newer version X.X.X.X as well"

Marking as:
New (Confirmed)
Normal (can prevent high quality work for German users)
High (somewhat major feature - synonyms would affect quite a few users)

Thanks for reporting!
Comment 4 A (Andy) 2015-02-06 21:50:12 UTC
For me not reproducible with LO 4.4.0.3, Win 8.1.

Because this bug is quite old, does it still persist in Linux?
Comment 5 QA Administrators 2016-02-21 08:36:44 UTC Comment hidden (obsolete)
Comment 6 Samuel Mehrbrodt (CIB) 2016-12-19 15:32:38 UTC
This looks fixed in 5.2.