Bug 59182 - Double scrollbar for special characters dialog
Summary: Double scrollbar for special characters dialog
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.0.0.0.beta2
Hardware: Other All
: lowest normal
Assignee: Caolán McNamara
QA Contact:
URL:
Whiteboard: target:4.1.0 target:4.0.0.2
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-09 22:23 UTC by vulcain
Modified: 2013-01-17 10:41 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Double scrollbar for special characters dialog (near the mouse) (82.42 KB, image/png)
2013-01-09 22:23 UTC, vulcain
Details

Note You need to log in before you can comment on or make changes to this bug.
Description vulcain 2013-01-09 22:23:04 UTC
Created attachment 72756 [details]
Double scrollbar for special characters dialog (near the mouse)

1) Launch Libo 4.0.0.0.beta2 (Build ID: 4104d660979c57e1160b5135634f732918460a0) on Ubuntu 12.04 x86_64 and select writer
2) Go to Menu -> Insertion -> Specials Caracters
3) On the right you can see two lift, one on another (seek the mouse on screencast). May be you need to select a special caracter, to have this behavior)

Expected: have only one lift

On french forum, it's reproduce on Vista or 7 with Libo 4.0 beta 2 and
same behavior with Version 4.0.0.1+ (Build ID: 075a1e6fdaebd441be4cb46fbc30ef7ded4caba) on Ubuntu 12.04.1 x86_64
Comment 1 Jorendc 2013-01-10 01:06:55 UTC
Thanks for reporting!

I can reproduce using Ubuntu 12.10 and LibreOffice 4.1.0.0.alpha0+ (Build ID: 92afb61d8bb1b264a945371065115981ecaed0f) (build on Januari 10 2013)

I lowered the priority to 'lowest', because the slider doesn't lost his function. This doesn't prevent the LibreOffice user to make quality work (you don't lose any document quality with it).
But, it's not that beautiful ;-).

Kind regards,
Joren
Comment 2 Jean-Baptiste Faure 2013-01-12 06:41:13 UTC
summary updated.

Caolan: Can you help here?

Best regards. JBF
Comment 3 Caolán McNamara 2013-01-14 16:58:13 UTC
I don't get quite the same problem, but there is some artifacts down the right and it "jumps around" a bit. Definitely my bug anyway
Comment 4 Not Assigned 2013-01-16 12:28:30 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3c8d3ef10267fb0a50686f49c15a3e4ab35503d1

Related: fdo#59182 stop SvxShowCharSet resizing itself



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 5 Not Assigned 2013-01-16 12:28:48 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=463f2d4fe211e991d551be67be74cf2090afdb7e

Related: fdo#59182 make SvxShowText::GetOptimalSize match its SetFont logic



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 6 Not Assigned 2013-01-16 12:29:05 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f1088250485fa91b4131102c5275e73653bc0c2c

Resolves: fdo#59182 make the special character dialog behave



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 7 Caolán McNamara 2013-01-16 12:44:37 UTC
I think that sequence of changes makes it all do the right thing now. Squashed them together for review for 4-0 as well.
Comment 8 Not Assigned 2013-01-17 10:41:01 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b43bd72c7d81b58c5f58a5c29fab7982878b5f63&h=libreoffice-4-0

Resolves: fdo#59182 make the special character dialog behave


It will be available in LibreOffice 4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.